MacOS client won't launch after reboot

Hi :wave:!

I have a strange problem with my macOS Nextcloud client. After installation I can use it fine, but when I rebooted macOS the app won’t launch see screenshot in german).
Bildschirmfoto 2022-04-01 um 17.05.57
When I run the installer again I can launch the app just fine. I run macOS 12.3.1 on an M1 Mac.

Can anyone help me finding the source of this problem?

1 Like

You can start the program from command line with activated logging:

Perhaps the question mark reveals more information as well.

Thank you for your answer!
Unfortunately the question mark reveals a blank (help-?) window.
When I start it from command line it only outputs:

[1] 14263 killed /Applications/ --logwindow

There are 4 Nextcloud Extensions processes in ActivityMonitor but I don’t know what to make of that.

Oh dear… when I select “open with Rosetta” in the information dialog it works just fine 🫥

I was under the impression that arm-mac is natively supported since 3.4.0 - I wonder why the installer would choose the x86 version then… Could this be some issue due to migrating the system from x86 Mac some months ago?

After installation it seems to run the arm version.

Bildschirmfoto 2022-04-02 um 17.35.33
(I use 3.4.4 currently downloaded directly from

We use v3.5.4 and the same behavior: It launches after installation but will never again after a reboot of the mac. Until now we always needed to reinstall, but I can confirm that the settings the “open with rosetta” option in the information dialog of the app (right click in finder, then information) solves the issue. I opened an issue for this: [Bug]: client app on M1 mac won't launch after reboot · Issue #4906 · nextcloud/desktop · GitHub

1 Like

ref: [Bug]: client app on M1 mac won't launch after reboot · Issue #4906 · nextcloud/desktop · GitHub