MacOs client not working when user is not admin of Mac

After installing macos client as a standard mac user, connection worked, first sync completed ok for a few hours. After restarting mac and login as same standard mac user, client does not show up, nor does it sync. Webdav works Ok. After opening a session as admin of mac, nextcloud opens up for login credentials and syncs (remember it was installed by standard user), All seems ok. Opening a new session on mac as previous standard user, nextcloud client does not workand does not sync. It seems there are some rights problems with the client. How to make it work as sstandard user with no admin privileges?

By default, I needs to be installed. There were a few topics about a portable version under Windows OS and how to build them. Not sure how portables can be build on a mac…

You could just access directly via webdav, that’s implemented in the OS and for occasional access that might be enough.

Thanks, but your answer does not help. I said I could access with webdav. I reinstalled the client as admin. client Login window appeared. Turned off computer. Lit up it again, logged in as standard user, nothing happens, client does not show up, can’t log into nextcloud. Logged in as admin, client works, login window appears and login works, closed the admin session, opened a new session as standard user and client works. This is reproduceable. Actually, I have no wish to debug source code on my mac. I am done with programming.

Then you can install as a user, normally it should then ask for the admin authentication to continue installation (it’s like this for other software). Even after the admin installed the software, it should be available through applications or spotlight: Nothing happens after app installation on macOS · Issue #2899 · nextcloud/desktop · GitHub

I am having exactly the same issue under macOS 11.6. Has there been any resolution so far?

When there are changes to the code, it is normally on github. So the best is to check there if you find issues that describe your problem. The linked github issue is not solved yet, not sure if that is exactly your problem, but if so, you can give it a thumbs up to show that you also have the problem. If you can provide more information, e.g. problem on different versions etc.