macOS address book can not sync


I have the following problem. I have two Macs (one Mac mini and one MacBook Pro) both running the latest version of macOS Sierra.

On the Mini I can use the address book of macOS without any problems. On my MacBook I got a warning triangle and the message: “Some server contacts could not be copied to this address book.”.

I double checked both Macs, both are using the same identical configuration/setup. Also they using the same software.

Had someone the same problem and a solution for this?


Hi - I tried this too and it did not work. I do sync my contacts with my iPhone with no problems. I was not able to find any documentation to troubleshoot it either.


I had a similar problem and found a solution in a other post i can’t find anymore but it helped me.
it sayed to qit the Addressbook and go to ~/Library/Preferences/ and delete the file named you can make a backup by renaming it somehow you remember…
If you then open Addressbook it will create a new file and that helped me to sort out some of the problems i had.
But not all. I also deleted the contacts and imported the backup i made from a fully synced source.
So that are two solutions you can try.
Regards, Novski

The tip with the ex and import was the trick for me! Thank you.
I make an export for all contacts, delete the existing group and create a new one, than I import the vcf and it worked.

Thanks! :slight_smile:

Hello, i had the same Problem.
IPhone worked but not my Contacts-App on the mac, like thehotiron.
The Soulution was the same like timscha.

Exported all Contacts from NC
Made a test-Import on a NC-Test-user
Deleted all Contacts on NC
Imported all Contacts with my Contacts-App on the mac (This App which had the Problem)
it works

Many Thanks!