“Machine learning models still need to be downloaded”

I have installed all the prerequisites for recognize and even got it working but now it is showing that the models still need to be downloaded. How would I do that please?

I’m running the beta channel fully up to date on Ubuntu 22.04.1 LTS

You can either let recognize attempt to do it automatically or run

occ recognize:download-models
4 Likes

I was in the app and didn’t scroll far enough to see that - d’oh! Thank you!

I have this installed in TrueNAS Scale 22.12.0. Where do I go to input the terminal command? I’ve seen posts elsewhere saying I need to open the shell for the Nextcloud container, but when I do that, it doesn’t recognize the occ command. A noob here, in case that was not clear :slight_smile:

Same question here. Should I run in the AIO container?

I tried to run the command in the nextcloud container, but I got these:

/var/www/html # ./occ recognize:download-models

Fatal error: Allowed memory size of 2097152 bytes exhausted (tried to allocate 491520 bytes) in /var/www/html/3rdparty/composer/autoload_real.php on line 35

Hi, see GitHub - nextcloud/all-in-one: Nextcloud AIO stands for Nextcloud All In One and provides easy deployment and maintenance with most features included in this one Nextcloud instance. for how to run occ commands in AIO

Bash commands do not work in the TrueNAS Scale 22.12.0 IX application container shell. It’s SH, not BASH. So I am still at a loss as to how to run occ commands.

Doing some hunting, I did make some slow progress, but not quite there yet:

root@nextcloud-7bff555c87-vkmmd:/var/www/html# su -m www-data occ recognize:download-models
occ: line 2: ?php: No such file or directory
occ: line 3: /bin: Is a directory
occ: line 4: syntax error near unexpected token (' occ: line 4: * Copyright (c) 2013 Thomas Müller thomas.mueller@tmit.eu

Have you guys tried?:

sudo -u www-data php /var/www/ < yourpathto > /nextcloud/occ recognize:download-models

Using the IX Systems official (blue) TrueNAS Scale version of Nextcloud, sudo is not a recognized command. So that command does not work, unfortunately.

SOLVED: after rummaging around over on the TrueNAS forums, this worked:

su -m www-data -c ‘php $(pwd)/occ recognize:download-models’

Is it possible for me to resolve this without access to the server console?

I use cloudhosting with Onyxcloud.de, and since its not an entire VPS I do not have access to the server console and cannot (to my knowledge) run occ commands…

Did you take a look at the requirements? I highly doubt this will work well on a shared hosting platform, if it will work at all.