Mac Desktop Sync Client Error Transferring - Server Replied: Not Found

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud Client version: 3.12.0 (build 20569)
Nextcloud Hub version: Nextcloud Hub 7 (28.0.2)
Operating system and version: MacOS Sonoma (14.2.1)
Nginx version : Nginx (2023/04/13)
PHP version: 8.2.13

The issue you are facing:

When installing the Nextcloud Desktop Client on a new m3 Macbook Pro, I go through the whole setup process and everything looks fine. I am able to sync empty folders.

I created an “upload” folder, when moving files of varying sizes into the synced folder I get the following error between 5-45 seconds after the sync starts:

“Error transfering https://nextcloud.‘mydomain’.com/remote.php/dav/files/‘username’/‘foldername’/‘filename’ - server replied: Not Found”

Is this the first time you’ve seen this error?:

I have not seen this issue before, other computes with similar settings are working as expected.

Steps to replicate it:

  1. Install Desktop Client
  2. In the setup process use “Choose Which Folders to Sync” and choose one folder to be used as an Upload Folder
  3. Drop file into “Upload Folder” and allow sync to process
  4. Error appears after 5 to 45 seconds of the file looking like it will upload as normal.

The output of your Nextcloud-Client log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'datadirectory' => '/data',
  'instanceid' => 'ocgwhhrs36br',
  'passwordsalt' => 'password',
  'secret' => 'secret',
  'trusted_domains' => 
  array (
    0 => '',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'mosaic-nextcloud',
  'dbhost' => '',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'mosaic-nextcloud-user',
  'dbpassword' => 'db-password',
  'installed' => true,
  'app_install_overwrite' => 
  array (
    0 => 'admin_notifications',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'filelocking.enabled' => true,
  'memcache.locking' => '\\OC\\Memcache\\APCu',
  'upgrade.disable-web' => true,
  'mail_from_address' => 'nextcloud',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => '',
  'loglevel' => 2,
  'maintenance' => false,

The output of your Apache/nginx/system log in /var/log/____:

  • No relevant log files (only logs are from previous dates, none from when the issue occurs)

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

Many logs are around OnlyOffice, which is a separate and not as important issue that I believe to be unrelated to this issue.

I’m having the same error popping up lately.

“server replied: Not Found”

But the directory is accessible both on my local machine (MacOS Ventura, latest point release, base M1) and on the server, through webui or app clients.
The only way I found to solve (temporarily) the bug is to force a resync.
To me, it happens both with the internal and the external drive, and usually after waking the machine up from sleep.

I tried already forcing the mac to not go to sleep, and to not put the hard drives to sleep, but it hasn’t worked.

PS: @nathan-mosaic the pastebin logs include your domain name, just to let you know since you removed it from the error log pasted in your post.

After doing a lot more digging, what fixed my issue was actually a “Chunking” issue in how the desktop client uploaded.

Here is the fix that worked for me. I set the “maxChunkSize” value to “99999999” and it has been working without issue on all client devices since making that change to the cfg file.

Hey thank you for the tip!
Can you send the link to the thread in the screenshot?

BTW I tried and it’s still not working for me, sadly.
It’s better, but it’s not fixed.