Mac desktop client sync failure

Nextcloud version: 22.2.0

Operating system and version: Ubuntu 20.04 LTS

Apache version: Apache 2.4.41

PHP version: 7.4.3

Nextcloud Desktop Client: Version 3.3.5 (macOS)

Hi NextCloud community,
I have recently installed NextCloud on a server hosted in a data centre and setup the NextCloud desktop client on my Mac.

I have added some folders from my Mac to NextCloud via the client. It synced like halfway through them. Since then it is checking for changes and when it is supposed to start syncing it gives me error messages and starts to check again for changes. This goes on and on without that anything is actually synced.

Screenshot 2021-10-05 at 10.21.28_censored

The NextCloud log gives me different error messages to which I could not yet really find any solution anywhere:

Fatal	webdav	Sabre\DAV\Exception\ServiceUnavailable: Could not open file
Error	PHP	Error: fopen(httpseek://): failed to open stream: "OC\Files\Stream\SeekableHttpStream::stream_open" call failed at /var/www/nextcloud/lib/private/Files/Stream/SeekableHttpStream.php#66
Error	PHP	Error: fopen([FOLDER-PARH]): failed to open stream: HTTP request failed! HTTP/1.1 500 Internal Server Error at /var/www/nextcloud/lib/private/Files/ObjectStore/S3ObjectTrait.php#78
Error	files_external	Aws\S3\Exception\S3Exception: Error executing "HeadObject" on "[FOLDER-PARH]"; AWS HTTP error: Server error: `HEAD[FOLDER-PARH]` resulted in a `500 Internal Server Error` response (server): 500 Internal Server Error (Request-ID: 16AB11792DF3221F) -
Fatal	webdav	Doctrine\DBAL\Exception\DeadlockException: An exception occurred while executing a query: SQLSTATE[40001]: Serialization failure: 1213 Deadlock found when trying to get lock; try restarting transaction

Does any one have any idea where the issue is and how I can solve it?

Thank you very much in advance for your kind support!

Is this just with the desktop app? The errors (S3 storage) look a bit more general, so do you have such issues on the webinterface as well?

Except for setups with very few files, it’s recommended to set up redis for the file locking cache. You have an error regarding this as well.

Thanks for the reply @tflidd

With the web interface I don’t have any issues.

As attempt to solve this issue I setup Redis yesterday with the following configuration:

'memcache.distributed' => '\OC\Memcache\Redis',
  'redis' => [
     'host'     => 'localhost',
     'port'     => 6379,
  'filelocking.enabled' => 'true',
  'memcache.locking' => '\OC\Memcache\Redis',

Also in the redis.conf I checked that the port is als set to 6379, uncomment Unix socket and change the permissions to 770: unixsocketperm 770 and also added the web server user to the Redis group.

Is there any issue with the settings?

When you use the socket, the ‘host’ is usually the socket address and the port 0:

  'redis' =>
  array (
    'host' => '/tmp/redis.sock',
    'port' => 0,

I had tried this first, but unfortunately then my server becomes unavailable. I just tried it again just to be sure.

Screenshot 2021-10-05 at 13.31.29

How do I know the correct socket address?

Mine here is from a FreeBSD system. Can be in /var/run/… but the full path is in the redis configuration file.

Alright. For some reason my NextCloud is not working when Redis is listening to the Unix socket. So, I set it back to localhost & port 6379. I also commented out Unix socket and unixsocketperm 770 in the the redis.conf.

Screenshot 2021-10-05 at 20.47.40_censored

I think Redis is working like that.