Mac desktop client does not start (Nextcloud- [NOT YET SOLVED]

I installed Nextcloud- and then opened /Applications/ I can see in Activity Monitor that a nextcloud process is started, but it doesn’t seem to do anything. No window is opened and no icon appears in the upper right to indicate that Nextcloud is active. I can only kill the process.

I also tried starting with logging options: /Applications/ --logdebug --logfile ~/nclog/nc.log --logflush

Still, nothing happens and no log file is created. Does anyone know how I can determine the problem?

I am including details. Please let me know if I can supply any other information.

System information
Nextcloud open files and ports
Nextcloud process sample

I should mention that the nextcloudcmd command-line utility does seem to work fine. Synchronization completed successfully.


I made some progress by starting MacOS in Safe Mode and installing and configuring Nextcloud as usual. Then, I restarted in normal mode. This time, the nextcloud process was unresponsive for maybe 30 seconds after Dropbox had started, but then the icon appeared as usual. Everything was fine.

However, it is back to the original problem on subsequent restarts. The process is there, using a small amount of memory and no CPU. No icon appears.

There must be a conflict with something else that gets started during a normal login. However, it’s a pretty fresh installation of MacOS. I installed Dropbox and not much else. I tried disabling Dropbox and iTunes Helper, leaving only Nextcloud as a login item. There was no change.

same problem here. I’ve tried yesterday to install Nextcloud client on a firend’s mac, and “nothing” happens while clicking on the app icon…

Developers are rarely here. So consider filing a bug report on


i’m afraid this is solving your pretty well documented problem for this forum since it seems that it’s a bug. bugs (issues) can be solved only by the devs and not by the forum. so the devs should get to know about it.
and that’s why @tflidd got the “solution” for your case.

i know it’s not really a solution in a good way, though.

it would be nice if you would post your issue here after filing it to github.