mac-Client reports SSL-Protocol Error when trying to connect

Hi there,

i use the latest Version of Netxcloud Server on my own Ubuntu 16.04 Server. The Website works perfect, login possible and everything goes fine. Not my Safari nor the latest google Chrome are reporting any SSL-Problems.

I then installed the mac-Client ( Version 2.2.4 on MacOS 10.12.3 ) and it’s reporting SSL-Protocol Error while trying to connect to my Server.

I’ve tried the same on my Windows 10 Notebook and here the Client connects without any problem. The iPhone-App also connects without any problems.

I’ve doublechecked the SSL-Settings / -Certificate via SSLLabs and everything is fine.

I’ve found another Thread according this topic, but it’s for Client 2.2.3 and from Sep 16 … no solution there. So please can anyone help me, how to get my mac-Client to work ?

i noticed that some mac clients have problems with sha512 signed certificates. maybe that’s the problem?

1 Like

not here, the signature algorithm is SHA256 with RSA

The client may have been compiled using the macOS’ stock OpenSSL library instead of the more updated library from Homebrew. https://github.com/nextcloud/client_theming/issues/13 I wish this could get fixed.

So, for this topic … not solved, no solution at the moment and keep waiting for release 2.x.x ?

Doesn’t seem like it, and I’m a bit surprised by the lack of responses. Seems like a vexing issue for more than a few people. It’s very odd to explain to our users that they need to keep using the ownCloud client even thought we’re now using Nextcloud.

1 Like

ownCloud Client was updated recently ( https://owncloud.org/changelog/desktop/ ) and the MacClient works pretty fine for me. Is there still no option, to upgrade the nextcloud Mac-Client ?

It’s a little confusing for me to use nextcloud as Server and ownCloud for Client-Sync :frowning:

Feel free to open a feature request on github.

There is already one: https://github.com/nextcloud/client_theming/issues/81

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.