Lost access to ubuntu (and nextcloud) aftera system restart (and perhaps an update)

i installed ubuntu core 18.04 a few months ago with nextcloud on a raspberry pi4. i also connected 2 mobile devices and the first experiment was successful. i closed it for that time until i had time to add an external storage device. i opened the device yesterday to add the harddisk i bought. after a few minutes of running, the system loaded, and i connected to it with ssh, as expected.
so far so good!

i faced the issue of a new ip (i didnt set a static ip address), and i started searching for a solution to that (edit the config.php).

while im on that, suddenly the ssh notifies me that the system restarted. i waited.
and since then i was waiting. i tried several rebooting. i tried even giving it a full night.
the ubuntu loads and stays forever in the loading screen with the logo in the center of screen.

i cant even access the recovery mode with esc button or 1 key or long press on shift (https://ubuntu.com/tutorials/how-to-ubuntu-core-recovery-mode#3-using-recovery-hidden-boot-menu).

i have 2 questions:

  1. does anyone have an idea how to solve it?
  2. assuming there is no solution, and i need to do a reinstall, what have i done wrong? how should i do it better?
  3. could i save my data that was already on the nextcloud? for now it is not yet an issue, but im more worried if this kind of issue would happen when i really put ALL my data into it.

thanks guys!

i don’t think the recovery-mode-keys you tried will work on a raspi since raspis do not use grub to boot.
you can take out the sdcard, mount it somewhere else and change its contents (that way i usually “install” a raspi). if the old files weren’t deleted you might be able to configure your raspi to use them again. keep in mind that you cannot use chroot for the raspi-os on a “normal” (i.e. x86) computer.
i just looked at THIS superficially but you might find some helpful stuff there.
yes, i think you should really and always backup your data :wink:

thank you pete for the effort to help.

when i first setup the installer i created it with IMAGER app. is that what you mean? but this will delete all the files, so i would say this should be last resort.

when i plug the sdcard to pc (i only have Windows), i see some folders, but no actual media files or docs. i dont see the standard system files or the nextcloud installation folder. so its unclear whats going on. perhaps it is due to the fact that im looking on it on a Windows system (and the sd is already formatted as ext4)? not sure about that.

when you say to install raspi : do you mean the OS of raspberry pi? like the ones from the link you shared? what would be different then? if i would have those or the GUI ones, it might be easier for the OS? should i not expect similar errors (since its on the boot)?