Login-Problem after LDAP-Connection

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5):
Operating system and version (eg, Ubuntu 20.04): Shared server
Apache or nginx version (eg, Apache 2.4.25): shared server
PHP version (eg, 7.4): 7.4

The issue you are facing:
I can’t login. What I did: I tried to connect to an ldap service. I entered all the details. After logging out of Nextcloud I wasn’t able to login anymore.

Is this the first time you’ve seen this error? (Y/N): Yes

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:

Can't enter the webinterface. Therefore no logfiles.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => '***',
  'passwordsalt' => '***',
  'secret' => '***',
  'trusted_domains' => 
  array (
    0 => 'nxt.***.de',
  'datadirectory' => '/is/htdocs/wp1056403_CRZ1BLA5TM/www/nxt/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'http://nxt.***.de',
  'dbname' => '****-nxt',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'db***-nxt',
  'dbpassword' => '****',
  'installed' => true,
  'mail_from_address' => '***',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => '***.de',
  'mail_smtphost' => 'wp***.mailout.server-he.de',
  'mail_smtpport' => '25',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'wp***',
  'mail_smtppassword' => '***',
  'mail_smtpauthtype' => 'LOGIN',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 0,
  'app_install_overwrite' => 
  array (
    0 => 'activitylog',
'auth.bruteforce.protection.enabled' => false,

The output of your Apache/nginx/system log in /var/log/____:

I can't access the logs as I'm using a shared server.