Logging stopped and cannot see new activity on it

Thanks for the great cloud software. I have been using it with great success and it is serving well. Two days ago I upgraded to latest version 11. I went under admin view to see some logs and trying to enable various levels I un-ticked all of the boxes and now nothing is getting logged even in /homedirectory/nextcloud/nextcloud.log This file is not being updated anymore? What did I do wrong? How do I enable the viewing of the tic boxes with their debug levels back in admin view?

Looks like I have to do some cli work to get them back. Any advice? Is this a bug?


I think there was a bug at some point. You can also edit the config/config.php and set the loglevel manually (0 is debug).

same issue Log file readability
for me changing this in the config/config.php has no effect

No matter what value you put in the config.php there is no log visibility in the admin view in the UI as before. I have to do a cat of the nextcloud.log in the cli to see what’s going on. It seems that this is a bug.


i Got mine back after a FATAL with ‘loglevel’ => 0 in the config.php

Just never disable anymore seems bug to me

I just tried it with a value of 0 and still the same, no logs in the admin view. I guess I have to wait for a fix or when software is updated with a newer version. Hopefully they will fix it quick. Yeah, if I knew this would happen I would have not disabled all the tick boxes.


If u have log_level problem, just execute this SQL code and all reverts back:

UPDATE `oc_appconfig` SET `configvalue` = '11111' WHERE `oc_appconfig`.`appid` = 'logreader' AND `oc_appconfig`.`configkey` = 'levels';

DON’T disable debug level or u’ll have “clean” logs again…

Agree with the above solution.
Disable everything showing in the logreader ERROR DEBUG INFO FATAL WARNING removes the menu link to enable it again.
Executing the above SQL Query solves the problem.

Tried multiple times and works 100% Thanks

Thank you! That did it. I guess I’ll make sure not to uncheck all options until they fix this issue.