Logging problem, NextCloud 13.0.3 redirects me!

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version :
Operating system and version: Debian 8
Apache or nginx version : Apache/2.4.10
PHP Version: 5.6.26-0+deb8u1

The issue you are facing: When I try to access to my NextCloud with my user and password, NextCloud redirects me mydomain.com/index.php to /index.php/login?redirect_url=/index.php/apps/files/, so I can not enter

Is this the first time you’ve seen this error? (Y/N): Yes

Steps to replicate it:

  1. I migrated OwnCloud to NextCloud
  2. I solved the problems with integrity
  3. I tryed to change my background and logo image
  4. I put a .jpg image
  5. When I log out, in tryed to log in again, I could not

** I put the custom theme ‘example’, and I cant log in anyway.

The output of your Nextcloud log in Admin > Logging:

I cant enter

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

'datadirectory' => '/var/www/owncloud/data',
  'overwrite.cli.url' => 'http://xxxxxx/owncloud',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'owncloud',
  'dbhost' => 'localhost',
  'dbtableprefix' => '',
  'dbuser' => 'xxxxx',
  'dbpassword' => 'xxxxxx',
  'logtimezone' => 'UTC',
  'installed' => true,
  'forcessl' => true,
  'mail_smtpmode' => 'php',
  'mail_from_address' => 'postmaster',
  'mail_domain' => 'xxxxxxxxx',
  'log_rotate_size' => '104857600',
  'maintenance' => false,
  'loglevel' => 3,

The output of your Apache/nginx/system log in /var/log/____: - - [08/Jun/2018:09:38:38 +0200] "GET /index.php/login?redirect_url=/index.php/apps/files/ HTTP/1.1" 200 4449 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.181 Safari/537.36"


{"reqId":"TFWEw70prlAbNXqtBcwP","level":3,"time":"2018-06-08T06:55:15+00:00","remoteAddr":"","user":"Adrian","app":"index","method":"GET","url":"\/data\/.ocdata?t=1528440672859","message":"Exception: {\"Exception\":\"Exception\",\"Message\":\"The requested uri(\\\/data\\\/.ocdata) cannot be processed by the script '\\\/owncloud\\\/index.php')\",\"Code\":0,\"Trace\":\"#0 \\\/var\\\/www\\\/owncloud\\\/lib\\\/base.php(951): OC\\\\AppFramework\\\\Http\\\\Request->getRawPathInfo()\\n#1 \\\/var\\\/www\\\/owncloud\\\/index.php(42): OC::handleRequest()\\n#2 {main}\",\"File\":\"\\\/var\\\/www\\\/owncloud\\\/lib\\\/private\\\/AppFramework\\\/Http\\\/Request.php\",\"Line\":733}","userAgent":"Mozilla\/5.0 (Macintosh; Intel Mac OS X 10_13_2) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/66.0.3359.181 Safari\/537.36","version":""}

Hello, same problem here. But I haven’t change the Logo.

@LexusMania @GustavoMognon
Try to update your .htaccess files:
sudo -u www-data php /path/to/nextcloud/occ maintenance:update:htaccess

Thank you so much MichaIng,

but the problem persist…

@LexusMania Take a look in this #9802

Thank you so much @GustavoMognon !

I owe you one :wink:

@LexusMania This solved your problem?

Best Regards.

@GustavoMognon Yes!, and yours?

@LexusMania I Had to roll back to owncloud (VM SNAPSHOT) … I’ll wait for the next release to try again…
I’m glad to hear that this fix worked for you!