Log file readability

Solution is to update a record in the table oc_appconfig with myql :

UPDATEoc_appconfigSETconfigvalue= '11111' WHEREoc_appconfig.appid= 'logreader' ANDoc_appconfig.configkey= 'levels';

For example,11111 to show all types or 00000 to hide.

2 Likes

I think that’s what I did finally :wink:

Cool. Thanks.
But that’s not really the solution for the average user, is it?

You have to be able to manage this from the GUI, right?

Indeed the top bar should just not disappear after deselecting all logs. Sadly I don’t see any browser console or other log that gives further information why this happens.

fine, it works!!!
thanks to all!!!
update row helped!!!

There is already an issue on github about it: https://github.com/nextcloud/logreader/issues/35

Maybe this topic might serve as motivation to start work on that issue @icewind :slight_smile:? Should be not hard to solve.

1 Like

Fix is https://github.com/nextcloud/logreader/commit/c77ee8186f61018afe78de41a4811e639e08edf9

2 Likes

Ah okay this fix was already applied one month ago, but since the last release is older, it did not make it into nextcloud 11.0.1?

I updated my logreader by

wget https://github.com/nextcloud/logreader/archive/master.zip
unzip master.zip
rm logreader
mv logreader_master logreader

checked if the committed file changes are there at some spots in the code and reloaded everything. But actually the problem still persists :frowning:. Did I do something wrong or can you confirm that @nickvergessen?

Hello. I was hit with this problem. I had updated my Owncloud 8.2.x to Nextcloud 11.0.1 following proper steps (I think) and with 11.0.1 installed I did unselect all log levels in the Admin -> Logging page and was affected by this problem.

When 11.0.2 is released will this patch be included and therefore I will be able to see my logs again in the web UI?

Yeah, it is not yet fixed in 11.0.1 but on github already merged to “stable11” branch: https://github.com/nextcloud/logreader/tree/stable11 “Keep table headers if no content is found”

So it will be present in 11.0.2 :slight_smile:. Until then it is as easy to fix as I mentioned above: Just take the current master from github.
It might take some time, browser cache clearing or what for the new version to take effect. I remember (also mentioned above) that for the first it did not change anything. But finally and just tested again: removing all logs does not remove the table header anymore.

Hi, thanks anyway, but it didn’t work for me. After doing as you suggested (in the nextcloud/apps directory) and fixing permissions and SE linux settings I could no longer go to the Admin page when logged into my Nextcloud instance. Replacing the original folder make it work again.

Guess I’ll just wait for 11.0.2.

Hmm, that is interesting. Maybe the most current master includes some new bug? I will try that by myself later.

to be clear, I have a running nextcloud version 11.0.1 then tried to swap out the logreader folder inside apps folder which caused me to not be able to load the Admin page at all (was just blank).

@lamixer Ha yeah, the current master has some bug, I am facing the same problem while trying to use it: Admin panel does not open with nextcloud 11.0.1, php 7.0 and apache 2.4.25.

After switching to stable11 branch, which is working as desired with table header bug fixed, I found the following error:

Error PHP Interface ‘OCP\Settings\IIconSection’ not found at /var/www/owncloud/apps/logreader/lib/Settings/Section.php#28

@icewind Should be easily able to fix it, or is the current master just for nc 12 without backwards compatibility?


So the steps to get the table header bug fixed for nc 11 at the moment are:

$ wget https://github.com/nextcloud/logreader/archive/stable11.zip
$ unzip stable11.zip
$ mv logreader logreader-bak (just in case)
$ mv logreader-stable11 logreader

master is only for nc12, important fixed will be backported to stable11 (stable11 should work on nc10 to)

thanks, that worked. had to reload the page a second time before I saw the change.

This post was flagged by the community and is temporarily hidden.

1 Like

Hello, Which external tools do you use for analysing the LOG ?
i am more non-IT person, and my NextCloud is not working so i cannot use the log reader inside NC .
pleas help.
i do not know why my first message was hidden by system.

hello Nick,
I do not know why my first message was hidden so i write again : it was trying to say : how the hack i may use the NextCloud log reader when my NextClloud is OFF (not working after update try) and i need to read the log ?

tail -f /var/log/apache2/error.log

1 Like