Loading icon without audio or video on remote calls (TURN server set up, ports forwarded - issue persists)

If I call on same network: No issues. (Video and audio start instantly.)
If I call on mobile/remote: Call shows user’s name and initial icon with a loading circle in the middle. Video and audio does not load on either end. Sometimes, the initials icon goes away to a black screen but with loading icon still overlayed. I was able to make a successful video call after about 8 retries, but issue returns. Issue is a more consistent issue on other people’s devices that are connected to their (basic I’m sure) residential networks.

  • So I went ahead and setup a TURN server on Unraid.
  • I then setup port forwarding on my pfsense router for ports 5349 and 3478 to go to my TURN server, UDP and TCP.
  • I even went on and made nginx reverse proxy for my.domain.com:5349 and my.domain.com:3478 to go to my TURN server. I’m not sure if this is even necessary.
  • I set up certificates on my turn server for same certs as my my.domain.com (just in case?)

When I set in Nextcloud Talk settings:
I set up 2 turn server items my.domain.com:5349 and my.domain.com:3478, as turn & turns for both, with same password as set on turn server, UDP and TCP. It checks for about 10~ seconds and then I get a red exclamation icon. If I click on the monitoring icon again, same result and checking duration.

Nextcloud version (eg, 24.0.1): 28.0.1
Talk Server version (eg, 14.0.2): 18.0.1
Custom Signaling server configured: No? I don’t know what this is or where it’s set.

The output of your Nextcloud log in Admin > Logging or errors in nextcloud.log in /var/www/:

Any ideas? Are there any Talk logs I can check?? Any ideas would be greatly appreciated.

TURN is not based on HTTP, so you can’t use nginx for that. The ports need to be used by coTURN directly. So point the port forwarding directly to the server which runs coTURN and make sure that nginx is not listening to these ports.
You can find information about TURN and how to test TURN at https://nextcloud-talk.readthedocs.io/en/latest/TURN/

Thank you for the clarification on no nginx!
Tried removing spreed and reinstalling, no change.

When I test my TURN server port as TCP I get
Connect: Operation timed out
connect: Operation timed out
0: : socket_connect: cannot connect to remote addr: 110
0: : socket_connect: cannot connect to remote addr: 110

And UDP just hangs after this (tried port 3478 too)
0: : IPv4. Connected from: [my server ip here]:59617
0: : IPv4. Connected from: [my server ip here]:59617
0: : IPv4. Connected to: [some other ip here]:5349
0: : IPv4. Connected to: [some other ip here]:5349
0: : allocate sent
0: : allocate sent

Maybe it’s my setup, I must have something wrong somewhere in this chain below?
Unraid server running 3 dockers: Nextcloud, Nginx Reverse Proxy, TURN server.
I have a DDNS set up for my subdomains to point to, which then goes to my Nginx Reverse Proxy docker. In the docker I have nextcloud.domain.com that points to the right port that my nextcloud docker uses. Maybe I don’t have the TURN server set up correctly for my setup? Do I create a separate turn.domain.com to use ports 80 (or 443) then? Or can I not use nextcloud.domain.com but with port 3478? I’m confused which port the TURN server should be listening to, then? I guess I’ll play more once my DNS syncs by tomorrow.

It doesn’t appear to be an issue with my setup. For the past few hours now I can’t even access the Talk settings. This is what I see below.

Sometimes if I give it 5 seconds it does load the fields and dropdowns again and there on it’s fine but then suddenly it doesn’t load again. :face_with_raised_eyebrow: :expressionless:

Anything I can try? What could be causing this?? It may be related that the Admin > Logging page also doesn’t load anything (at all tho).