Linux Desktop Client not starting on system start

I am using Xubuntu 16.04.2 on my laptop, synchonised via the Nextcloud desktop client with my Nextcloud Box (RPi2)

I have the box in the Nextcloud desktop client for launch on system startup ticked but the client never starts on system startup and I have to start it manually

I have checked in ‘Session and Startup’ and ‘Nextcloud’ is listed there with the command ‘/usr/bin/nextcloud’

Any ideas?


Try to set a start delay of 5 or 10 seconds

Thanks, tried sleep 10 && nextcloud with no luck

I have also seen the below mentioned

xterm -e 'sleep 10 && nextcloud'
bash -c "sleep 10 && nextcloud"
Exec=sh -c "sleep 20; nextcloud"

And also I had originally /usr/bin/nextcloud and not just nextcloud

Before I work through all combinations, is there a prefered method for this?


I have it set in “Startprograms” in Linux Mint:

Settings with delay:

I am on Xubuntu that doesnt have (I think) this built in
I will try the other ways using /usr/bin/nextcloud and see what happens

I also have this issue on several computer, all running various flavors of ubuntu 16.04., all up to date.
Could you solve the problem with the delay, @leigh?

No, still same with 18.04 and have problems opening manually
I had forgotten about this thread and I opened another.
I had even forgotten about how to do delay.

Current thread, now with Xubuntu 18.04