Linux client won't log in

TL;DR

Been trying to find out how to get support here.

My linux client worked fine for many months, if not a years. Suddenly I can’t get it to connect. Keeps logging in successfully in the web browser, but the nextcloud client just says "You have been logged out of … as user … Please login again.

can’t find support on the nextcloud website… form just keeps saying "there was a problem… " Aggravation on top of aggravation.

I am having the same issue on Arch Linux running Mate desktop. I deleted and re-added the folder connection, but that only works for a one time use. After the next login it fails to log in. It will launch the browser and I authenticate on my site, but the nextcloud desktop app never gets the message and fails to log in. Once that happens you get the message, “You have been logged out on xxx@yyyy.net as user zzzz” for every button I click.

Perhaps you can/must delete the old sessions in the user defined security settings in the web interface of Nextcloud.
settings -> security

I’ve tried that. Opening the desktop app launches the browser, I’m able to log in and grant access but still the desktop app never gets the message back from the browser session.

Perhaps you can revoke the device in Devices & sessions

I have the same problem here. And I already tried to revoke the session – didn’t help.

Nextcloud has been updated to 3.3.2 on tuesday (sep 1st), but problems appeared only after a restart.
My clients are running on Ubuntu 20.04, Server is Nextcloud 21.0.4