Link zu pdf Dokument in IE wird nicht korrekt angzeigt

Hallo

Habe zu testzwecken das Dokument - Nextcloud User Manual.pdf als Link geteilt.
Funktioniert im Firefox problemlos
Funktioniert im Chrome auch

Im Internet Explorer
nur links kleines Fenster, dass überlagert wird

Mach Ich was falsch?

Bitte um möglichst rasche Antwort da es so unbenutzbar ist!
LG
Witzker

Hallo und Herzlich willkommen!
Also ganz zuerst mal ist das hier die falsche Kategorie, du hast das Thema erstellt, als du im Abschnitt “filelink” warst, dadurch wurde das Thema auch in Filelink erstellt. Filelink ist eine Thunderbirderweiterung für Nextcloud. Für deine Frage wäre die Kategorie “support” die richtige. Das müsste aber z.B. @jospoortvliet verschieben, da ich dazu keine Rechte habe :confused:

Wenn es dir möglich ist, schreibe doch bitte auch auf englisch, damit fremdsprachige Nutzer ebenfalls von der Lösung profitieren.

So nun zu deinem Problem:
Wenn ich das richtig verstanden habe ist dir das Inhaltsverzeichnis im Weg. Das Inhaltsverzeichnis kannst du einklappen, indem du oben links das Icon links neben der Lupe anklickst. Dann verschwindet das Fensterchen.

Wenn das Problem behoben ist, markiere doch zur besseren Übersichtlichkeit die richtige Antwort am betreffenden Post. Beispiel:

Summary for our english friends:

  • Told him this is the wrong subject.
  • Asked him to speak English.
  • His problem is a window that slides ahead of the PDF display.
  • The solution is to click the icon in the upper left corner next to the zoom icon.
  • Told him to mark the right answer if a problem was solved.

THX for your answer Info & hints

I think the post will be shifted correctly THX

here again my problem with better sceenshot

Nothing is displayed in the right window

in Firefox the same link looks like this:

How to achieve the same result in IE
grafik

Hope for help to be able to use Nextcloud for our demands

regards
Witzker

UFF Ahm… Okay…
The *-server.css says that the widh of the container is only 300px. It’s a bug in Nextcloud.

As workarround you need to replace it with “100%”, see attached picture:

  1. Right click on pdf, click “Inspect element” (Element untersuchen)
  2. Navigate in the developer console left side to div id “app-content”
  3. Replace the value on the right side

I’ve created an issue on https://github.com/nextcloud/server/issues/11665

Ok THX

When and how will this be fixed?
that people with IE can open my link correctly
(I am new here)
Regards witzker

Just have a look on the github Issue i’ve linked. At the moment just this stupid, worthless nextcloud-bot answered me but I think there will be some other guys to clear that

So
Now a new update is out still not fixxed!

Whats going on?

Sorry, I guess it just has low priority - if no volunteer has time for this it has to come from a paid engineer and they of course prioritize issues from customers. That is how it works in an open source project.

Besides why not use Firefox or Chromium? What home user uses IE 11… :wink:

Hallo
Was Wird?

It was said that it is low priority. You can try to fix it yourself, put a bounty on the bug via bountysource.com, buy Nextcloud support or use Firefox/Chrome, or wait. There is also a hint in one post, where you can find the properties in the css files: https://github.com/nextcloud/server/issues/11665#issuecomment-427684487

THX for reply

I am new with this stuff

grafik

Does that mean when I put this in the files on the server the problem is solved?

In The ie.scss I have this:
#app-sidebar {
position: fixed !important;
}
#app-content {
width: $navigation-width !important;
}
#app-sidebar.disappear {
right: -$sidebar-max-width !important;
}

in the variables.css I have this:
grafik

PLS Help HowTo

No, it sounded more it could be related to these settings. IE seems to interpret them differently. In Firefox you can use the webdeveloper tools to play around with the css settings and see the impact on the interface, not sure if that exists for IE as well (or as a plugin).