Letsencrypt und HTTPS Weiterleitung

Hallo Leute!

Ich werde jetzt echt noch beim Thema Zertifikat und der Weiterleitung zu HTTPS irre!!! :frowning:

Ich habe heute mit folgenden Befehlen Letsencrypt installiert (denke ich):

sudo nano /etc/apt/sources.list
deb http://ftp.debian.org/debian jessie-backports main

danach

gpg --keyserver pgpkeys.mit.edu --recv-key  8B48AD6246925553
gpg -a --export 8B48AD6246925553 | sudo apt-key add -
gpg --keyserver pgpkeys.mit.edu --recv-key  7638D0442B90D010
gpg -a --export 7638D0442B90D010 | sudo apt-key add -

weiter mit

sudo apt-get update

anschliessend

sudo apt-get install python-certbot-apache

und

sudo apt-get install certbot

Laut Anleitung dann weiter vorgegangen

sudo certbot --apache
sudo certbot certonly --standalone -d example.com

example.com wurde selbstverständlich durch meine Domain ‘nextcloud.xxxxxx.at’ ersetzt.

Im Verzeichnis ‘/etc/letsencrypt/live/nextcloud.sptech.at/’ habe ich nun vier *.pem Files liegen

cert.pem
chain.pem
fullchain.pem
privkey.pem

Jetzt habe ich dann meinem Verständnis nach die Files ‘cert.pem’ und ‘privkey.pem’ in die ‘default-ssl.conf’ unter den Punkten ‘SSLCertificateFile’ und ‘SSLCertificateKeyFile’ eingetragen und das ganze mit ‘sudo a2ensite default-ssl.conf’ aktiviert. Und jetzt lässt sich mein Apache2 nicht mehr starten oder neu starten. Es lässt sich zwar mit ‘sudo a2dissite default-ssl.conf’ wieder deaktivieren, das ändert aber leider nicht daran das mein Apache2 nicht mehr will.

Die Fehlermeldung bei Start von Apache2 lautet:

Job for apache2.service failed because the control process exited with error code.
See "systemctl status apache2.service" and "journalctl -xe" for details.

Wenn ich ‘systemctl status apache2.service’ ausführe sehe ich folgendes:

apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2018-04-04 11:42:09 CEST; 51s ago
  Process: 7621 ExecStop=/usr/sbin/apachectl stop (code=exited, status=0/SUCCESS)
  Process: 8351 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)
 Main PID: 7536 (code=exited, status=0/SUCCESS)

Apr 04 11:42:08 raspberrypi systemd[1]: Starting The Apache HTTP Server...
Apr 04 11:42:09 raspberrypi apachectl[8351]: AH00526: Syntax error on line 4 of /etc/apache2/sites-
Apr 04 11:42:09 raspberrypi apachectl[8351]: Invalid command 'RewriteEngine', perhaps misspelled or
Apr 04 11:42:09 raspberrypi apachectl[8351]: Action 'start' failed.
Apr 04 11:42:09 raspberrypi apachectl[8351]: The Apache error log may have more information.
Apr 04 11:42:09 raspberrypi systemd[1]: apache2.service: Control process exited, code=exited status
Apr 04 11:42:09 raspberrypi systemd[1]: Failed to start The Apache HTTP Server.
Apr 04 11:42:09 raspberrypi systemd[1]: apache2.service: Unit entered failed state.
Apr 04 11:42:09 raspberrypi systemd[1]: apache2.service: Failed with result 'exit-code'.

Wie kann ich den ganzen Blödsinn wieder rückgängig machen? Und kann mir jemanden eine funktionierende und vernünftige Anleitung zur Installation und Weiterleitung schicken???

Bin für jeden Hinweis dankbar.

Just4Info

In das ‘000-default.conf’ habe ich folgendes eingetragen zur Weiterleitung:

<VirtualHost *:80>
   ServerAdmin sascha@localhost

   RewriteEngine On
   RewriteCond %{HTTPS} off
   RewriteRule ^(.*)$ https://%{HTTP_HOST}$1 [R=301,L]
</VirtualHost>

::UPDATE::

Ich habe meinen Apache2 wieder zum starten überreden können. Die ‘000-default.conf’ habe ich wieder auf Standard zurück gesetzt so wie die ‘default-ssl.conf’

Alles richtig gemacht, nur es wurde ServerName in 000-default.conf und default-ssl.conf vergessen, somit konnte Certbot nicht die Serverdomain auslesen. Ist aber jetzt gelöst und geregelt :slight_smile:

1 Like

Vielen Dank für die Unterstützung STrike!

Du warst echt eine große Hilfe!!!