Letsencrypt (Certbot) erzeugt Fehler

Hallo zusammen,

nachdem meine nextcloud nun läuft (lokal kann ich über 192.168.XXX.XXX, sowie extern über meine_domain.myfritz.net darauf zugreifen), möchte ich den SSLZugang einrichten.
Hierfür habe ich certbot verwendet, erhalte nur leider immer wieder eine Fehlermeldung.

Ich habe dietpi-letsencrypt im Terminal gestartet und folgende Parameter eingegeben:
domain = meine_domain.myfritz.net
email: nextcloud@YYY.de
Redirect = ON
HSTS = OFF
Key Size = 4096 bits

Nachdem Letsencrypt scheinbar gut anläuft kommt dann eine Fehlermeldung:
[Failure] CertBot failed with error code (1), please check its terminal output. Aborting…

Unter /var/log/letsencrypt/letsencrypt.log finde sich folgende Infos:

2020-04-13 18:39:29,808:DEBUG:certbot.main:certbot version: 0.31.0
2020-04-13 18:39:29,809:DEBUG:certbot.main:Arguments: [’–webroot’, ‘-w’, ‘/var/www’, ‘–agree-tos’, ‘–no-eff-email’, ‘–rsa-key-size’, ‘4096’, ‘-m’, ‘nextcloud@YYY.de’, ‘-d’, ‘meine_domain.myfritz.net’]
2020-04-13 18:39:29,811:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#manual,PluginEntryPoint#null,PluginEntryPoint#standalone,PluginEntryPoint#webroot)
2020-04-13 18:39:29,836:DEBUG:certbot.log:Root logging level set at 20
2020-04-13 18:39:29,836:INFO:certbot.log:Saving debug log to /var/log/letsencrypt/letsencrypt.log
2020-04-13 18:39:29,845:DEBUG:certbot.plugins.selection:Requested authenticator webroot and installer None
2020-04-13 18:39:29,846:DEBUG:certbot.plugins.selection:Single candidate plugin: * webroot
Description: Place files in webroot directory
Interfaces: IAuthenticator, IPlugin
Entry point: webroot = certbot.plugins.webroot:Authenticator
Initialized: <certbot.plugins.webroot.Authenticator object at 0xb5449cb0>
Prep: True
2020-04-13 18:39:29,846:DEBUG:certbot.plugins.selection:Selected authenticator <certbot.plugins.webroot.Authenticator object at 0xb5449cb0> and installer None
2020-04-13 18:39:29,847:INFO:certbot.plugins.selection:Plugins selected: Authenticator webroot, Installer None
2020-04-13 18:39:29,871:DEBUG:certbot.main:Picked account: <Account(RegistrationResource(body=Registration(key=None, contact=(), agreement=None, status=None, terms_of_service_agreed=None, only_return_existing=None, external_account_binding=None), uri=‘https://acme-v02.api.letsencrypt.org/acme/acct/83289978’, new_authzr_uri=None, terms_of_service=None), 150879601e2e6a38c28732e492de8145, Meta(creation_dt=datetime.datetime(2020, 4, 13, 12, 12, 24, tzinfo=), creation_host=‘DietPi’))>
2020-04-13 18:39:29,872:DEBUG:acme.client:Sending GET request to https://acme-v02.api.letsencrypt.org/directory.
2020-04-13 18:39:29,880:DEBUG:urllib3.connectionpool:Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org:443
2020-04-13 18:39:30,572:DEBUG:urllib3.connectionpool:https://acme-v02.api.letsencrypt.org:443 “GET /directory HTTP/1.1” 200 658
2020-04-13 18:39:30,573:DEBUG:acme.client:Received response:
HTTP 200
Server: nginx
Date: Mon, 13 Apr 2020 16:39:30 GMT
Content-Type: application/json
Content-Length: 658
Connection: keep-alive
Cache-Control: public, max-age=0, no-cache
X-Frame-Options: DENY
Strict-Transport-Security: max-age=604800
{
“W9Xl_NcwOWo”: “https://community.letsencrypt.org/t/adding-random-entries-to-the-directory/33417”,
“keyChange”: “https://acme-v02.api.letsencrypt.org/acme/key-change”,
“meta”: {
“caaIdentities”: [
letsencrypt.org
],
“termsOfService”: “https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf”,
“website”: “https://letsencrypt.org
},
“newAccount”: “https://acme-v02.api.letsencrypt.org/acme/new-acct”,
“newNonce”: “https://acme-v02.api.letsencrypt.org/acme/new-nonce”,
“newOrder”: “https://acme-v02.api.letsencrypt.org/acme/new-order”,
“revokeCert”: “https://acme-v02.api.letsencrypt.org/acme/revoke-cert
}
2020-04-13 18:39:30,577:INFO:certbot.main:Obtaining a new certificate
2020-04-13 18:39:44,945:DEBUG:certbot.crypto_util:Generating key (4096 bits): /etc/letsencrypt/keys/0007_key-certbot.pem
2020-04-13 18:39:44,997:DEBUG:certbot.crypto_util:Creating CSR: /etc/letsencrypt/csr/0007_csr-certbot.pem
2020-04-13 18:39:44,999:DEBUG:acme.client:Requesting fresh nonce
2020-04-13 18:39:44,999:DEBUG:acme.client:Sending HEAD request to https://acme-v02.api.letsencrypt.org/acme/new-nonce.
2020-04-13 18:39:45,165:DEBUG:urllib3.connectionpool:https://acme-v02.api.letsencrypt.org:443 “HEAD /acme/new-nonce HTTP/1.1” 200 0
2020-04-13 18:39:45,166:DEBUG:acme.client:Received response:
HTTP 200
Server: nginx
Date: Mon, 13 Apr 2020 16:39:45 GMT
Connection: keep-alive
Cache-Control: public, max-age=0, no-cache
Link: https://acme-v02.api.letsencrypt.org/directory;rel=“index”
Replay-Nonce: 0001DSnDa8UITMoVCNYp8upwwRGzPJVPcXBSzF4a-Ovy_dA
X-Frame-Options: DENY
Strict-Transport-Security: max-age=604800
2020-04-13 18:39:45,166:DEBUG:acme.client:Storing nonce: 0001DSnDa8UITMoVCNYp8upwwRGzPJVPcXBSzF4a-Ovy_dA
2020-04-13 18:39:45,167:DEBUG:acme.client:JWS payload:
b’{\n “identifiers”: [\n {\n “type”: “dns”,\n “value”: “meine_domain.myfritz.net”\n }\n ]\n}’
2020-04-13 18:39:45,210:DEBUG:acme.client:Sending POST request to https://acme-v02.api.letsencrypt.org/acme/new-order:
{
“protected”: “eyJhbGciOiAiUlMyNTYiLCAia2lkIjogImh0dHBzOi8vYWNtZS12MDIuYXBpLmxldHNlbmNyeXB0Lm9yZy9hY21lL2FjY3QvODMyODk5NzgiLCAibm9uY2UiOiAiMDAwMURTbkRhOFVJVE1vVkNOWXA4dXB3d1JHelBKVlBjWEJTekY0YS1PdnlfZEEiLCAidXJsIjogImh0dHBzOi8vYWNtZS12MDIuYXBpLmxldHNlbmNyeXB0Lm9yZy9hY21lL25ldy1vcmRlciJ9”,
“signature”: “LsXWKZLZY2BC6ttjn3NMhXd8AvrgOU0h5-oov71BJ3uT0uxVb7ZZyYFe1WiJAb6j3JOd9KakeVvejYNynQI69kHbVn1rTNFlf_PIPV56SQBOkrOQQzPEGBcWzC4jB-SmjLwGlPPaMcHD9fDc-3cOhOlPfnqXFLN3hJBQu8fViZyiLvV5jtBeSkB2EKVyo_F3p_n3Y91dgyc4VkTsQymeIeyqvryopTjeAY5AJIrdRiFbJzrVLwXJJMyps7o7_M7Nhl71k-BnfghnOjBIkWftVsqjFf3yFBE8BkSxUfB1PTJgJFz75R90DV4URcLIOG6b56gvYhcvtWMaDrUsWoaQhAEnPqJ68OhVkdWYsIhqSQMssgz99GSWxxVZ9iO4uD2oUgbtId8DNIxHgi_tvWLhwGACpHtv7l1YdQbjmeAMjlz0ZXCr0CnBRGhiRoemL3lyZNFKpU_7E1VmxxvLzz_tiul1KKjRRiCRqSAOrR0go_s07xUeJ_o1x_j-SPljRGWsP1z4vVGEcGP5AMzMMuC3AElOespFeBP2snKOi2IuMH_a9Bl5as2A6lm7-JdZZUm8ZmOylbmkxFQVhk0wVi2Bmos576m26wINcKR0aTw8GHdI9hZUGDW60Wk26XeDBe1JxUtM2SOilh8KJK8P6-O5Pr_b-ebg_ZhnMaXgJOn-0IE”,
“payload”: “ewogICJpZGVudGlmaWVycyI6IFsKICAgIHsKICAgICAgInR5cGUiOiAiZG5zIiwKICAgICAgInZhbHVlIjogInFremVodmF4azk0YmxobnEubXlmcml0ei5uZXQiCiAgICB9CiAgXQp9”
}
2020-04-13 18:39:45,408:DEBUG:urllib3.connectionpool:https://acme-v02.api.letsencrypt.org:443 “POST /acme/new-order HTTP/1.1” 201 357
2020-04-13 18:39:45,409:DEBUG:acme.client:Received response:
HTTP 201
Server: nginx
Date: Mon, 13 Apr 2020 16:39:45 GMT
Content-Type: application/json
Content-Length: 357
Connection: keep-alive
Boulder-Requester: 83289978
Cache-Control: public, max-age=0, no-cache
Link: https://acme-v02.api.letsencrypt.org/directory;rel=“index”
Location: https://acme-v02.api.letsencrypt.org/acme/order/83289978/2989270905
Replay-Nonce: 0002Bs3SmmRCAqldwy_l9ETT1GPXw9D4OiP3BXMDQcL5vjA
X-Frame-Options: DENY
Strict-Transport-Security: max-age=604800
{
“status”: “pending”,
“expires”: “2020-04-20T16:39:45.31439377Z”,
“identifiers”: [
{
“type”: “dns”,
“value”: “meine_domain.myfritz.net”
}
],
“authorizations”: [
https://acme-v02.api.letsencrypt.org/acme/authz-v3/3938284668
],
“finalize”: “https://acme-v02.api.letsencrypt.org/acme/finalize/83289978/2989270905
}
2020-04-13 18:39:45,409:DEBUG:acme.client:Storing nonce: 0002Bs3SmmRCAqldwy_l9ETT1GPXw9D4OiP3BXMDQcL5vjA
2020-04-13 18:39:45,410:DEBUG:acme.client:JWS payload:
b’’
2020-04-13 18:39:45,453:DEBUG:acme.client:Sending POST request to https://acme-v02.api.letsencrypt.org/acme/authz-v3/3938284668:
{
“protected”: “eyJhbGciOiAiUlMyNTYiLCAia2lkIjogImh0dHBzOi8vYWNtZS12MDIuYXBpLmxldHNlbmNyeXB0Lm9yZy9hY21lL2FjY3QvODMyODk5NzgiLCAibm9uY2UiOiAiMDAwMkJzM1NtbVJDQXFsZHd5X2w5RVRUMUdQWHc5RDRPaVAzQlhNRFFjTDV2akEiLCAidXJsIjogImh0dHBzOi8vYWNtZS12MDIuYXBpLmxldHNlbmNyeXB0Lm9yZy9hY21lL2F1dGh6LXYzLzM5MzgyODQ2NjgifQ”,
“signature”: “DVvgBJfHWorvY9ivmtvt05YxguzYyh0jd3fZ6NV00DzDpNhkaoG8b8CFQBCnzs2N_nhsbS8MfS3-DeZy5NZjzZFfISofijUw8eBVyCLx3wqEJK1cdh3xUkDRNCrAy1dsxYtpLwOKT8iovX4iA8PNPVsfOjOAzwgDZwKmdUCfPzQIUWSFhvUsD-OUcNZNztJYv5_jGwHA6NTcoybttQETIhOU_qTaWYJJGYZJ7iZrU9e5YheqMHqgmlVthDz_9dJFYhn0BP_F0j8v0K1U3jSd8WggxaawaBKw8DXA4NiiTwSwggGdv9AuQEgkUQcnO9wGwTw9wI0ExLbzCNpZy5upngaewFZxQTC3kiAuVO3buRHghjsacPRaUb194BKhCKJXCxPk7KYbMTA2FdwVdidVXev60hTs_cXAldQlEieS7RQgpHFJSmJwE5O3KCYSepdRPHPrL0rZGb8GGui4bINv3gu1vOuOfMnlwHgkxrzNtTPk08bojBom8ZRzCo_FMi8M6jGMkv6CDPf5QHJwCQw1cKXFgFIpiXJqKNwXdMW2B5X89POuWzsxAz4TYxGmzCSEH1xyZ6NfofdQDVpxUbG9Vueds7jFfldz5UnUHai2aE8yXCsIC-2yz9neAatk-LLGtimLSGv4zoee_hRpKwdZO0ACRZfaZh3e-zToaqUdy6E”,
“payload”: “”
}
2020-04-13 18:39:45,622:DEBUG:urllib3.connectionpool:https://acme-v02.api.letsencrypt.org:443 “POST /acme/authz-v3/3938284668 HTTP/1.1” 200 806
2020-04-13 18:39:45,623:DEBUG:acme.client:Received response:
HTTP 200
Server: nginx
Date: Mon, 13 Apr 2020 16:39:45 GMT
Content-Type: application/json
Content-Length: 806
Connection: keep-alive
Boulder-Requester: 83289978
Cache-Control: public, max-age=0, no-cache
Link: https://acme-v02.api.letsencrypt.org/directory;rel=“index”
Replay-Nonce: 0002jc4mX3MNlhVHzdY86LKiXnvMcT92isE7efl7g1BKEO8
X-Frame-Options: DENY
Strict-Transport-Security: max-age=604800
{
“identifier”: {
“type”: “dns”,
“value”: “meine_domain.myfritz.net”
},
“status”: “pending”,
“expires”: “2020-04-20T16:39:45Z”,
“challenges”: [
{
“type”: “http-01”,
“status”: “pending”,
“url”: “https://acme-v02.api.letsencrypt.org/acme/chall-v3/3938284668/_Klaaw”,
“token”: “R7KjvCU2jtBfftMWzYDn0Hi2Yxzf9T480wKDz-oxqmU”
},
{
“type”: “dns-01”,
“status”: “pending”,
“url”: “https://acme-v02.api.letsencrypt.org/acme/chall-v3/3938284668/gn6erw”,
“token”: “R7KjvCU2jtBfftMWzYDn0Hi2Yxzf9T480wKDz-oxqmU”
},
{
“type”: “tls-alpn-01”,
“status”: “pending”,
“url”: “https://acme-v02.api.letsencrypt.org/acme/chall-v3/3938284668/xnXf9Q”,
“token”: “R7KjvCU2jtBfftMWzYDn0Hi2Yxzf9T480wKDz-oxqmU”
}
]
}
2020-04-13 18:39:45,624:DEBUG:acme.client:Storing nonce: 0002jc4mX3MNlhVHzdY86LKiXnvMcT92isE7efl7g1BKEO8
2020-04-13 18:39:45,625:INFO:certbot.auth_handler:Performing the following challenges:
2020-04-13 18:39:45,625:INFO:certbot.auth_handler:http-01 challenge for meine_domain.myfritz.net
2020-04-13 18:39:45,626:INFO:certbot.plugins.webroot:Using the webroot path /var/www for all unmatched domains.
2020-04-13 18:39:45,626:DEBUG:certbot.plugins.webroot:Creating root challenges validation dir at /var/www/.well-known/acme-challenge
2020-04-13 18:39:45,643:DEBUG:certbot.plugins.webroot:Attempting to save validation to /var/www/.well-known/acme-challenge/R7KjvCU2jtBfftMWzYDn0Hi2Yxzf9T480wKDz-oxqmU
2020-04-13 18:39:45,644:INFO:certbot.auth_handler:Waiting for verification…
2020-04-13 18:39:45,644:DEBUG:acme.client:JWS payload:
b’{\n “resource”: “challenge”,\n “type”: “http-01”\n}’
2020-04-13 18:39:45,687:DEBUG:acme.client:Sending POST request to https://acme-v02.api.letsencrypt.org/acme/chall-v3/3938284668/_Klaaw:
{
“protected”: “eyJhbGciOiAiUlMyNTYiLCAia2lkIjogImh0dHBzOi8vYWNtZS12MDIuYXBpLmxldHNlbmNyeXB0Lm9yZy9hY21lL2FjY3QvODMyODk5NzgiLCAibm9uY2UiOiAiMDAwMmpjNG1YM01ObGhWSHpkWTg2TEtpWG52TWNUOTJpc0U3ZWZsN2cxQktFTzgiLCAidXJsIjogImh0dHBzOi8vYWNtZS12MDIuYXBpLmxldHNlbmNyeXB0Lm9yZy9hY21lL2NoYWxsLXYzLzM5MzgyODQ2NjgvX0tsYWF3In0”,
“signature”: “wZpkif-nSb_oUmdfURSLGDBBPhQ0VPwRU85bVu8sfE7Tm73P8MF0-up7fhH9xtrP4O69wn3JnCShLYhdt5skb0_xJk41NwKrdDpSL38EDYTW0L93O64NpQYYSkiZfjDwBEX4G6sZMLG2KKNtU0Ty9dnRuuL99Djjk4zjaz_ZBIUsoyS3kb7rcLDHiZf7aY5JibW-iza8_f-0ejeN950PTjc0VcKAkBNCVuic-JNAnkeOMLujPixO4tkG76i-3myXWYcFUUvKqng7o99Kt289xSBvtEeZZU1aVnm2_gVLqryVjyjsUR-rleCW5UE5LbleZpp9iuhL7_P1citiG4itr6moHVaGO7aL2FQ_6x05VdMC_JU7slFW8W22IzKbjjs2QGQXUSbRyWBI4MdXr-GTKyYNB2k9Jof-HB-Mav-lXtGaYUSPioSMWf8ct20ClW9V4ymMXXKaynMl0w04p17X6e3S_Foku0V7Cnt2T9HgoxfqOZgMk2BUv4ZQj2mJ8viqzI7q429SEivHcp0y6LfDJbPwwL3HVKFTPcltSnO4udQ5h_lCMYS3TiS1zSVNB0kMI_xyZ64EfNPXZR6vZUSVLsekD94IvkHAgwb7aeU4l-si2GcU2nFRgBPyAXSuYcLm53Sz9_TOKWYr9v8G_eFUful_K1v5hVbSqOS5XJfdU4Q”,
“payload”: “ewogICJyZXNvdXJjZSI6ICJjaGFsbGVuZ2UiLAogICJ0eXBlIjogImh0dHAtMDEiCn0”
}
2020-04-13 18:39:45,859:DEBUG:urllib3.connectionpool:https://acme-v02.api.letsencrypt.org:443 “POST /acme/chall-v3/3938284668/_Klaaw HTTP/1.1” 200 185
2020-04-13 18:39:45,860:DEBUG:acme.client:Received response:
HTTP 200
Server: nginx
Date: Mon, 13 Apr 2020 16:39:45 GMT
Content-Type: application/json
Content-Length: 185
Connection: keep-alive
Boulder-Requester: 83289978
Cache-Control: public, max-age=0, no-cache
Link: https://acme-v02.api.letsencrypt.org/directory;rel=“index”, https://acme-v02.api.letsencrypt.org/acme/authz-v3/3938284668;rel=“up”
Location: https://acme-v02.api.letsencrypt.org/acme/chall-v3/3938284668/_Klaaw
Replay-Nonce: 0002rR4Uug0rknHyE3Fz9_2ur1jy8M2NCESpF-R8Ow4oadw
X-Frame-Options: DENY
Strict-Transport-Security: max-age=604800
{
“type”: “http-01”,
“status”: “pending”,
“url”: “https://acme-v02.api.letsencrypt.org/acme/chall-v3/3938284668/_Klaaw”,
“token”: “R7KjvCU2jtBfftMWzYDn0Hi2Yxzf9T480wKDz-oxqmU”
}
2020-04-13 18:39:45,860:DEBUG:acme.client:Storing nonce: 0002rR4Uug0rknHyE3Fz9_2ur1jy8M2NCESpF-R8Ow4oadw
2020-04-13 18:39:48,864:DEBUG:acme.client:JWS payload:
b’’
2020-04-13 18:39:48,926:DEBUG:acme.client:Sending POST request to https://acme-v02.api.letsencrypt.org/acme/authz-v3/3938284668:
{
“protected”: “eyJhbGciOiAiUlMyNTYiLCAia2lkIjogImh0dHBzOi8vYWNtZS12MDIuYXBpLmxldHNlbmNyeXB0Lm9yZy9hY21lL2FjY3QvODMyODk5NzgiLCAibm9uY2UiOiAiMDAwMnJSNFV1ZzBya25IeUUzRno5XzJ1cjFqeThNMk5DRVNwRi1SOE93NG9hZHciLCAidXJsIjogImh0dHBzOi8vYWNtZS12MDIuYXBpLmxldHNlbmNyeXB0Lm9yZy9hY21lL2F1dGh6LXYzLzM5MzgyODQ2NjgifQ”,
“signature”: “swkeo597XKqlfSMFwYLhSFDioiuUcs2FRwdtIFHdKWAkMJKYd47D7A3xzqz61cFHXHWDL3CPEk0xuBmABR3G0KAK5GkTmB30SuBVki0lyiKdOF1kMUlvSDS12QP35uO0P7Pd9KEEbS60JqCk5V6Qdnvo3rrtziGiBL1RQdRH0YvgGnlrzo4AHUvatHulNZfI_KBe6yf3a21W60HyQKaXALyct-AMUZkMlFal4UtSGn6Gj2QoYICwVQM__Yt1BWYpa5bUx4IPygErVC8ce3l_6Ctq2co31hFcoNqPCmXHD1wvV_GukBLdg8R7OTusu7BlDQ0VOWBPTXWF2aVgzV7tHpuAbhfcyzjKlYl3uoYcLSZbQfa5Wf6jnh8RJLHEdCV8IC4XQ21xeT8oJrGUv-7dudgm6euQtldcmNUF7vYZ1OK716MpqipP5B0QdoE6FIqF5EqwXvhECz0nQo_wJk9WJcQhGrKGtdLGra18EacRNkU-QS3Fp3UhNP3_glwl19WIhofepaoRbqlO5t2FnpxJiS8hxXlJ24vpB7iIYzlQresWHgSohy0kXgt9ZAsnFdqmWOv6AH4TqVGwS4EJiqsbWfGIOO4uB7tdXiIrCF_SVPuM9_KDZdO4THzuAO0KCEmIBcehdeema9jq60LW9T7-5_pheN2q_yEbqSvWWgcI3Xs”,
“payload”: “”
}
2020-04-13 18:39:49,095:DEBUG:urllib3.connectionpool:https://acme-v02.api.letsencrypt.org:443 “POST /acme/authz-v3/3938284668 HTTP/1.1” 200 1682
2020-04-13 18:39:49,096:DEBUG:acme.client:Received response:
HTTP 200
Server: nginx
Date: Mon, 13 Apr 2020 16:39:49 GMT
Content-Type: application/json
Content-Length: 1682
Connection: keep-alive
Boulder-Requester: 83289978
Cache-Control: public, max-age=0, no-cache
Link: https://acme-v02.api.letsencrypt.org/directory;rel=“index”
Replay-Nonce: 000130PGW_tV5rPAqjYnflfabwcX50j9od4tr3sMzZ9GoVg
X-Frame-Options: DENY
Strict-Transport-Security: max-age=604800
{
“identifier”: {
“type”: “dns”,
“value”: “meine_domain.myfritz.net”
},
“status”: “invalid”,
“expires”: “2020-04-20T16:39:45Z”,
“challenges”: [
{
“type”: “http-01”,
“status”: “invalid”,
“error”: {
“type”: “urn:ietf:params:acme:error:unauthorized”,
“detail”: “Invalid response from http://meine_domain.myfritz.net/.well-known/acme-challenge/R7KjvCU2jtBfftMWzYDn0Hi2Yxzf9T480wKDz-oxqmU [83.135.176.75]: “\u003c?xml version=\“1.0\” encoding=\“iso-8859-1\”?\u003e\n\u003c!DOCTYPE html PUBLIC \”-//W3C//DTD XHTML 1.0 Transitional//EN\”\n \“http://www.”",
“status”: 403
},
“url”: “https://acme-v02.api.letsencrypt.org/acme/chall-v3/3938284668/_Klaaw”,
“token”: “R7KjvCU2jtBfftMWzYDn0Hi2Yxzf9T480wKDz-oxqmU”,
“validationRecord”: [
{
“url”: “http://meine_domain.myfritz.net/.well-known/acme-challenge/R7KjvCU2jtBfftMWzYDn0Hi2Yxzf9T480wKDz-oxqmU”,
“hostname”: “meine_domain.myfritz.net”,
“port”: “80”,
“addressesResolved”: [
“83.135.176.75”,
“2001:16b8:2702:350e:9ec7:a6ff:fe0f:5e7c”
],
“addressUsed”: “2001:16b8:2702:350e:9ec7:a6ff:fe0f:5e7c”
},
{
“url”: “http://meine_domain.myfritz.net/.well-known/acme-challenge/R7KjvCU2jtBfftMWzYDn0Hi2Yxzf9T480wKDz-oxqmU”,
“hostname”: “meine_domain.myfritz.net”,
“port”: “80”,
“addressesResolved”: [
“83.135.176.75”,
“2001:16b8:2702:350e:9ec7:a6ff:fe0f:5e7c”
],
“addressUsed”: “83.135.176.75”
}
]
}
]
}
2020-04-13 18:39:49,097:DEBUG:acme.client:Storing nonce: 000130PGW_tV5rPAqjYnflfabwcX50j9od4tr3sMzZ9GoVg
2020-04-13 18:39:49,098:DEBUG:certbot.reporter:Reporting to user: The following errors were reported by the server:
Domain: meine_domain.myfritz.net
Type: unauthorized
Detail: Invalid response from http://meine_domain.myfritz.net/.well-known/acme-challenge/R7KjvCU2jtBfftMWzYDn0Hi2Yxzf9T480wKDz-oxqmU [83.135.176.75]: "<?xml version=\"1.0\" encoding=\"iso-8859-1\"?>\n\n<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Transitional//EN\"\n \"http://www." 2020-04-13 18:39:49,103:DEBUG:certbot.error_handler:Calling registered functions 2020-04-13 18:39:49,103:INFO:certbot.auth_handler:Cleaning up challenges 2020-04-13 18:39:49,104:DEBUG:certbot.plugins.webroot:Removing /var/www/.well-known/acme-challenge/R7KjvCU2jtBfftMWzYDn0Hi2Yxzf9T480wKDz-oxqmU 2020-04-13 18:39:49,104:DEBUG:certbot.plugins.webroot:All challenges cleaned up 2020-04-13 18:39:49,105:DEBUG:certbot.log:Exiting abnormally: Traceback (most recent call last): File "/usr/bin/certbot", line 11, in
load_entry_point(‘certbot==0.31.0’, ‘console_scripts’, ‘certbot’)()
File “/usr/lib/python3/dist-packages/certbot/main.py”, line 1365, in main
return config.func(config, plugins)
File “/usr/lib/python3/dist-packages/certbot/main.py”, line 1250, in certonly
lineage = _get_and_save_cert(le_client, config, domains, certname, lineage)
File “/usr/lib/python3/dist-packages/certbot/main.py”, line 121, in _get_and_save_cert
lineage = le_client.obtain_and_enroll_certificate(domains, certname)
File “/usr/lib/python3/dist-packages/certbot/client.py”, line 410, in obtain_and_enroll_certificate
cert, chain, key, _ = self.obtain_certificate(domains)
File “/usr/lib/python3/dist-packages/certbot/client.py”, line 353, in obtain_certificate
orderr = self._get_order_and_authorizations(csr.data, self.config.allow_subset_of_names)
File “/usr/lib/python3/dist-packages/certbot/client.py”, line 389, in _get_order_and_authorizations
authzr = self.auth_handler.handle_authorizations(orderr, best_effort)
File “/usr/lib/python3/dist-packages/certbot/auth_handler.py”, line 82, in handle_authorizations
self._respond(aauthzrs, resp, best_effort)
File “/usr/lib/python3/dist-packages/certbot/auth_handler.py”, line 168, in _respond
self._poll_challenges(aauthzrs, chall_update, best_effort)
File “/usr/lib/python3/dist-packages/certbot/auth_handler.py”, line 239, in _poll_challenges
raise errors.FailedChallenges(all_failed_achalls)
certbot.errors.FailedChallenges: Failed authorization procedure. meine_domain.myfritz.net (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://meine_domain.myfritz.net/.well-known/acme-challenge/R7KjvCU2jtBfftMWzYDn0Hi2Yxzf9T480wKDz-oxqmU [83.135.176.75]: "<?xml version=\"1.0\" encoding=\"iso-8859-1\"?>\n<!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Transitional//EN”\n “http://www.”

Weiß jemand, was hier falsch läuft?

Vorab schon einmal vielen Dank.

hilft die diese antwort vielleicht? denn der bot beklagt sich, dass das bei dir nicht richtig aufgesetzt zu sein scheint:

ich glaube nicht, dass es mit myfritz.net funktioniert, die Domain gehört dir nicht, ich habe es damit nicht geschafft. Verwende daher eine eigene Domain, und DynamicDNS.

hmmm. die fritzeigenen ssl-zertifikate sind aber auch von letsencrypt… und werden anstandslos akzeptiert.
und sämtliche ddns-provider vergeben auch nur subdomains im stil von sub.domain.tld, vergleichbar mit der sub.myfritz.net - rein logisch spräche m.E. nichts dagegen, dass das funktioniert

Ich hab den Hinweis von Norry mal aufgenommen und einen alten NOIP-Account reaktiviert.
Mit der neu erstellten DYNDNS kann ich wieder auf die nextcloud zugreifen. :+1:
Allerdings schlägt auch dieses Mal die Erstellung des SSL-Zertifikats wieder fehl. :disappointed_relieved:

Nochmal zurück zu dem Punkt mit der “Invalid Response” und der Location “/.well-known/acme-challenge” - was hat das auf sich? Wo muss ich denn etwas hinzufügen / einstellen?
Das hat sich mir noch nicht so ganz erschlossen.

nochmal eine Frage: Port 80 ist in der FritzBox weitergeleitet?
Das Ding hat einen anderen Namen als meine_domain, oder?

Hallo zurück,

ja, Port 80 und 443 sind beide auf dietpi (nextcloud) weitergeleitet.
Komisch ist nur, dass wenn ich jetzt meine_domain.myfritz.net im Browser eingebe, dass ich nicht zum Anmeldefenster der nextcloud, sondern auf die Fritzbox, bzw. zum Anmeldefenster von MyFritz! geleitet werde - sehr komisch. :thinking:

Das muss ich mir heute Abend nochmal anschauen, wenn Homeoffice vorbei ist. :smile:

Ach ja, und meine_domain.myfritz.net ist natürlich nicht die richtige Adresse, sondern irgendwas krytisches wie z.B. akeoifllaweivn.myfritz.net (aber auch das ist nicht die wahre Adresse) :wink:

die Befürchtung hatte ich, dass die FritzBox die Adresse wegschnappt, schau mal in der Konfig der FB nach, worauf der Serviceport läuft.

Moin,

also ich habe gerade nochmal ein paar Test durchgeführt:
Aktuell habe ich sowohl die alte owncloud an der Fritzbox hängen, als auch die neue nextcloud.

Sicherheitshalber habe ich soeben nochmal die letzte Sicherung der Fritzbox wieder eingespielt, sprich der Stand mit der Portweiterleitung ist wieder wie vor ein paar Monaten.

Zugriff auf die alte owncloud:
192.168.178.32 - OK (http://)
meine_domain.myfritz.net - FALSCH (leitet unverschlüsselt auf die Fritz.Box)
Das ist sehr eigenartig. Da ich mir das Verhalten nicht erklären kann, habe ich die Adresse in der Browserzeile noch 2 mal hintereinander aktualisiert und - siehe da - jetzt gelange ich auch auf die owncloud. Sehr mysteriös.

Sorry, was genau meinst du?
Wo soll ich was nachschauen?

wenn sich die FB auf eine URL meldet, kann Certbot das Zertifikat nicht verifizieren, das war meine Befürchtung, sowohl auf http als auch https muss dein Server reagieren.

OK, ich habs soeben nochmal ausprobiert.
Die nextcloud ist lokal per http erreichbar, https funktioniert nicht.
Beim ersten Versuch (http:) ist die nextcloud auch über meine_domain.myfritz.net.
Klasse, also per admin eingeloggt und gleich versucht, per CERTBOT das Zertifikat zu erstellen.
Dies ist wieder einmal fehlgeschlagen.

Danach habe ich mich ausgeloggt, den Browser-Tab geschlossen und in einem neuen Tab wiederum versucht, über meine_domain.myfritz.net auf die nextcloud zu kommen.
Seitdem komme ich immer nur auf das Login-Fenster per Fritzbox… :face_vomiting:
So ein Mist, das macht doch überhaupt keinen Sinn.

OK, also lassen wir die Fritzbox-DNS außen vor.
Also habe ich versucht, über NOIP auf die nextcloud zu kommen.
Das funktioniert sehr gut. Per Admin einloggen funktioniert auch.
Zerfitikat per CERTBOT erstellen schlägt aber auch hier leider wieder fehl.

Es erscheint auch immer wieder der Hinweis zu .well-known/acme-challenge
Muss ich ggf. in der nextcloud noch einstellen, dass ich https-Verbindungen zulasse?
Ich kann mich dunkel daran erinnern, dass ich sowas damals in der owncloud auch in irgendeiner php-Datei einstellen musste.

Ach ja, hier noch die Einstellungen der Portweiterleitung:

Hier passt also alles und temporär funktioniert es ja auch mit MyFritz.
Mit NOIP funktioniert es übrigens zuverlässiger - also der Zugriff per http:

ich kenne Noip nicht. Hast du da eine Domain?

Klar doch: www.noip.com

Welches DynamicDNS verwendest du?

schon klar, aber hast du da eine eigene Domain?

ich hab dir hier

habe ich auch deshalb, weil bei einem Wechsel/Defekt der FB eine neue Adresse zugewiesen wird.

naja, eine eigene Domain habe ich nicht, sondern nur eine kostenfreie DynDNS Weiterleitung: wolkenspeck.freedynamicdns.net

hmm dann geht das auf die myfritz url? Ein Konstrukt was ich nicht kenne und nicht durchschaue.

Habe mir meine FB Konfiguration mal angesehen:
Habe bei mir für den Server selbstständige Portfreigabe aktiviert
FB Dienste gehen auf Port 444

Beantragst du mit Certbot eine Zertifikat für wolkenspeck.freedynamicdns.net?

https://wolkenspeck.freedynamicdns.net/ ist nicht erreichbar

Nein, die MyFritz habe ich jetzt rausgelassen.
Die http://wolkenspeck.freedynamicdns.net/ (Achtung: kein SSL) geht direkt auf die Cloud.
https: funktioniert halt noch nicht… :disappointed_relieved:

Ja, habe ich bereits probiert, aber da bekomme ich auch wieder die Fehlermeldung “unauthorized”…

dann versuchen wir mal das Problem .well-known zu klären. Dazu die Frage nginx oder apache2?

Servus,

ich verwende Lighttpd (was standardmäßig installiert)…