Let's encrypt on non standard port: no access with android


I installed let’s encrypt yesterday for my Raspi nextcloud. The nextcloud is setup to use ports 801 and 4433. To install the certificate, I temporarily routed external ports 80 and 443 to the above ports and started the lets encrypt process via my dyndns address. Afterwards I reconfigured my router again.

The access to the nextcloud from a browser works pretty well. The certificate is up and running.

As soon as I want to connect with my android apps, the connection is refused: I logged out and try to login via the dyndns address. The password is accepted since I am forwarded to the TTOP. But afterwards I will directed to the first mask again to enter the server address.

Any idea how to get rid of the problem?

Hi @androidin

I’m not sure what exactly is causing the problem. But you could try manually generating an app password for the android app and login with that instead of using your regular password and TOTP via Browser when setting up the app.

Or you could just use the default ports. Using obscure ports mainly causes problems and gives you little to no additional security. Plus you have to manually renew the certificates every 60-90 days if you do it like this…