LDAP users don't appear after a search

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 28.0.2
Operating system and version (eg, Ubuntu 20.04): Ubuntu Server 22.04
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.52
PHP version (eg, 7.4): PHP 8.1.2

The issue you are facing: My Nextcloud is connected to our LDAP server (Active Directory).
All of our users appear in the Users section, but if I click on the User icon at the top right of the window, or if I perform a search in the Users section, the window becomes blank. Of course I’m searching for an existing user. It’s as if my users are not indexed.
Even when I’m trying to make an internal share link to some of them, if I type the names of my users, nothing appear. Same thing when I want to allow some users to access to my external storages.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Connect to LDAP
  2. Try it (connecting to NC with an user from LDAP with success)
  3. Connect with any user (even admin), and click on the top right contact icon to observ it’s empty.

The output of your Nextcloud log in Admin > Logging:

Nothing relevant

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'SECRET',
  'passwordsalt' => 'SECRET',
  'secret' => 'SECRET',
  'trusted_domains' => 
  array (
    0 => 'SECRET',
    1 => 'SECRET',
  'datadirectory' => '/var/www/html/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'SECRET',
  'dbname' => 'SECRET',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'SECRET',
  'dbpassword' => 'SECRET',
  'skeletondirectory' => '',
  'maintenance_window_start' => 1,
  'filelocking.enabled' => true,
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => 'localhost',
    'port' => 6379,
    'timeout' => 0,
    0 => 0,
    'password' => '',
  'installed' => true,
  'mail_domain' => 'SECRET',
  'mail_from_address' => 'SECRET',
  'mail_smtpmode' => 'smtp',
  'mail_smtphost' => 'SECRET',
  'mail_smtpport' => '25',
  'mail_smtpstreamoptions' => 
  array (
    'ssl' => 
    array (
      'allow_self_signed' => true,
      'verify_peer' => false,
      'verify_peer_name' => false,
  'default_phone_region' => 'FR',
  'default_locale' => 'fr_FR',
  'updater.release.channel' => 'stable',
  'maintenance' => false,
  'auth.webauthn.enabled' => false,
  'theme' => '',
  'loglevel' => 2,
  'mail_sendmailmode' => 'smtp',
  'defaultapp' => 'files',
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',