LDAP user password change, requires current password to be sent

Hi,

I’m setting up a nextcloud instance with an openldap authentication service based upon Fusion Directry.
I’m also trying to get users to change their password through nextcloud, but am having some trouble setting it up.

When I try to change a password, nextcloud tells me it is “Unable to change password”.
When I do a tcpdump on the server I can see the response from the ldap server is : “Must supply old password to be changed as well as new one”

But when I disable that feature in Fusion Directory’s password policy, it is still not possible to change the password.
I have tried to add the entryUUID to the ldap search filter, like mentioned in this topic;

In the debug loggin of ldap I can see that the ldap service account is trying to alter the user’s password information, but that it isn’t allowed. Only the user may change the password (security policy). Is there anyway i can send the old password with the request to change the password to my ldap server?