LDAP groups are empty, but users are showing their groups

Hi,

I have successfully configured Nextcloud 23 to connect to LDAP and users can authenticate. What is bothering me is that, while the groups are found and displayed on the “Users” section, and while I see group membership on each user’s row, when I click on a group on the sidebar, no user is shown.

That is, user A is member of group A_G, it shows on his row. Group A_G shows on the sidebar, but when I click there, it doesn’t show A (nor any member).

Any clue on how to solve this?

Best,
Francis

Hi,

Exact same problem for me.
Users are synced and can login (ldap authentication). Groups membership seems okay on the user list.
image

Group membership also works for Group Folders (user sees the group folder, based on their ldap groups).
image
image

Groups are also listed, however they show no members:
image

Same result with occ group:list, command returns groups names but no member.

Trying to play with ldap filters, but no change so far.

Nexctcloud 23.0.

Hope someone has an idea :slight_smile:

Aurélien

What worked for me was to set group membership to AD on the expert settings. Let me knowing you don’t find them.