Latest Collabora fails to start since it can't find my certs

I’m running Nextcloud 16 (16.0.7) and I went to update my server today. It installed Collabora 6.2 with loolwsd 4.2.0-2.

Loolwsd now fails to start loolwsd[20813]: Not found: storage.ssl.cert_file_path

I’ve opened a ticket at Collaboraonline about this, but has anyone else encountered this issue or a way around it? I’ve su’d to the lool user and I can see the files in question.

I can’t go back a version of loolwsd since apt stopped caching my debs for some reason. I’m hoping someone can help.

Same here.
Permissions are right. Even using relative path on cert, loolwsd do not find the file.

<cert_file_path desc="Path to the cert file" relative="false">/etc/loolwsd/cert.pem</cert_file_path>

I’ve tried to rename the cert to cert.pem (as in dist package example config), but no success.

I figured it out. Every time loolwsd updates, there’s a new /etc/loolwsd/loolwsd.xml file that needs to be updated by hand if you’ve made any modifications like certificates. Plus it formats the xml file differently every time there’s an update.

Mostly, the new entries don’t seem to make much difference. This time they added an SSL section under storage. If you don’t make any adjustments to that file, you should probably just put the new version in.

I’m not sure if it uses ssl with wopi or just webdav.

Thanks, that was the problem.
It seems that ssl block has to be inside storage block too. I’ve copied my setting in there, and all is workinkg again :slight_smile:

Thanks for the info, that helped me out as well.
I had made changes to loolwsd.xml and had copied over most of the difference with the new file, but had skipped the SSL section and it wasn’t working. Adding in the SSL section allowed it to run again.

Thanks again.