Latest Borg Restore missing from list of backups

Nextcloud AIO v7.11.2
Ubuntu 22.04

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): Y

I designed my Nextcloud install with the following in mind:

Use virtualbox on linux mint
After running perfectly, copy the nextcloud folder to a secondary drive incase of failure.
Make daily borg backups from the AIO interface

Well, the unthinkable happened. Today my Nextcloud server crashed and when restarting got a failure in the boot partiton.

I copied over my backup nextcloud VB folder and ran it. It starts as planned.

I had planned to go to the AIO interface and restore the most recent successful backup which was last night 4/25/24.

What I don’t understand is the latst backup showing on the list is dated
2024-02-13 - which was the latest backup before I refreshed my copy of the vm.

If I go to the borg mount point /mnt/borg/borg, I can see all the files of the backup with the dates of April 2024.

I thought rebooting NC would refresh the list, NO
I thought there might be a way to get NC to refresh the list, nothing found in my google searches.

How can I get NC to show the most recent backups?

Please help ASAP, wife needs some files restored.


Hi, if you look here, there is a hint how you can refresh the list: GitHub - nextcloud/all-in-one: 📦 The official Nextcloud installation method. Provides easy deployment and maintenance with most features included in this one Nextcloud instance.

Thank you

I looked through that link and didn’t see anything specifcally about refreshing the list, just to get a borg list. However it said once I enter the passphrase I should see something like “20220223_174237-nextcloud-aio” however all I got was a list of files with numbers as names as thats only from the cli

The list I want to refresh is this:

AIO Borg Restore

Any idea how I can do that?

ok I tried borg list again and got the proper date format. My last backup shows yesterday’s date:
20240426_030140-nextcloud-aio Thu, 2024-04-25 20:01:41 [d1c1379c51c58a19f48080f1afea2d52067e7237a4f603e21b6d53755cc70c2c]

How can I restore that? or refrsh the AIO list to show that?
I did a keyword search for Restore on that link but found no instructions

OK I figured it out.

The backup of NC notified me that a container update was available. I didn’t update because I thought the restore would take care of that.
Then I thought maybe the older containers can’t see newer backups so I updated the containers and the backup list is now up to date.

OK so I dont have it.
I did get the backups and started a restore, but then NC shutdown because I forgot to stop a cronjob for autmatic shutdowns then it wouldnt start up again.
I copied over the backup VM again, updated the mastercontainer but this time the backup list did not update so I’m back at square 1. Guess I just got lucky last time.

After doing so, make sure to update the backup archives list in the AIO interface!
You can do so by clicking on the Check backup integrity button or Create backup button.

Backup Integrity worked and restore successful.

Thank you very much

1 Like