Keine Verbindung zu Nextcloud Android App ├╝ber LTE

Ich hab Nextcloud 20.04 zu Hause auf einem lokalen Linux-Server unter Debian 10 am laufen.
Nach au├čen ist der Server ├╝ber eine Domain erreichbar, wessen IP ├╝ber DynDNS per Fritzbox geupdated wird. Dazu habe ich ein Lets Encrypt Zertifikat.

Wenn ich zu Hause im WLAN bin kriegt die Android App einen Connect zu dem Linux Server ├╝ber https://nextcloud.domainname.de
Die Android App kriegt jedoch keine Verbindung zu dem HeimServer wenn ich unterwegs bin und ├╝ber LTE verbunden, dann bekomme ich die Meldung ÔÇťServer nicht verf├╝gbarÔÇŁ. (Auch wenn ich die App neu einrichte kommt sofort diese Meldung).

Man w├╝rde auf dem ersten Blick sagen, dass der Router (Fritzbox) den Port von Au├čen nicht durchl├Ąsst. Dem ist aber nicht so, was folgender Test zeigt.

Gehe ich unter Android weiterhin per LTE Verbunden in den Chrome Browser und tippe ein
https://nextcloud.domainname.de bekomme ich ganz normal den Login Bildschirm, kann
mich einloggen und auf alle Daten zugreifen.

Wo ist der Wurm begraben?

Kann es sein, dass Du im LTE-Netz nur eine IPv6-Adresse zugewiesen bekommst, Dein DynDNS aber nur IPv4 unterst├╝tzt oder Du im Router nur eine Port-Weiterleitung f├╝r IPv4 eingerichtet hast, obwohl dieser auch eine IPv6 zugewiesen bekommt, etc.

In der Fritzbox wird Port 443 f├╝r Ipv4 und Ipv6 weitergeleitet.

W├Ąre es ein IPv6 Problem, dann w├╝rde ich unter LTE im Android Chrome doch auch keine Verbindung bekommen?

edit:

Hab unter Android mit einer App per IPv4 die Fritzbox angepingt und bekomme eine Antwort, d.h. unter LTE hab ich sowohl IPv4 als auch IPv6 (wenn ich in Chrome wie wieistmeineip.de besuche werden auch beide IP Adressen angezeigt).

Hast du mal versucht ├╝ber lte die app via ip adresse zu verbinden? Ist keine dauerl├Âsung, da dynamisch, aber es l├Ąsst einen schritt ausÔÇŽ