Kann mich nicht einloggen (Internal Server Error)

Hallo, seit gestern 17.06. können wir uns nicht mehr auf unsere NextCloud einloggen.
Komischerweise ging es ein paar Mal. Nun aber wieder nicht mehr.
Die Login Oberfläche geht. Download geht auch, wenn man einen Link klickt,

Sobald man sich einloggen möchte, erscheint folgendes:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Logfile ist bei 16.06. stehen geblieben. Das heisst wir können noch nicht mal in das Logofile schauen.

Operating system and version : Ubuntu 16.04.6 LTS‬
PHP version: 7.3.19

Jemand vielleicht eine Idee? Wenn ja, welche Info werden noch benötigt?

Vielen Dank

Ich könnte mir vorstellen, dass es eher am Webserver (z. B. Apache2) liegt.

Du könntest mal im Browser mit der Option F12 dir die Netzwerkanalyse anschauen und schauen, welche Requests noch gerade ausgeführt werden und welche nicht. Poste Screenshots davon.

Auch kannst du auf der Kommandozeile mal die Webseite manuell aufrufen. Gehe dafür in das entsprechende Verzeichnis. Poste evtl. Fehler.

php index.php

Welche Nextcloud-Version nutzt du überhaupt? Du wirst wohl auf kurz oder lang auf am besten Ubuntu 20.04 LTS (oder gerne auch Debian 10 :wink: ) umsteigen müssen. Die PHP-Version musst du ja schon aus irgendwelchen anderen Quellen nachgezogen haben. Irgendwann wird dir dein (fast) veraltetes Ubuntu-System zusammenbrechen auch wenn es offiziell noch bis 2021 (Desktop) und 2024 (Server) supportet wird.

https://wiki.ubuntu.com/Releases

Hallo Devnull, vielen Dank für die schnelle Antwort.
Ich habe mal zusammen getragen was ich finden konnte.

Hier das Bild von der Netzwerkanlyse:

In der Kommandozeile bekomme ich folgende Meldung:

This version of Nextcloud requires at least PHP 7.2 You are currently running 7.0.33-0ubuntu0.16.04.6. Please update your PHP version

Komisch, da PHP 7.3.19 ausgwählt ist und es vorgestern noch problemlos lief.

Die Nextcloud Version müsste mit 18 beginnen. Leider weiß ich nicht um welche es sich genau handelt.
Vorgestern hätte ich noch ein Update machen können. Da ich mich ja nicht einloggen kann, kann ich leider nicht genau sagen.

Wir haben ein Plesk System wo ich die anderen Daten wie Ubuntu und die PHP Version herhabe.
Wir sind bei Hosteurope gehostet. Mir unerklärlich warum das System nicht aktuell gehalten wird.
Werde ich mal prüfen.

Gruß Stefan

Schau mal hier:

Bevor du was änderst poste bitte:
dpkg -l |fgrep php

Ist ausreichend.

Im Prinziup ist Ubuntu 16.04 LTS noch aktuell. Trotzdem sollte man mit neuem Release (alle zwei Jahre) dann irgendwann auch mal dist-upgraden. Jetzt ist bereits 2020. Ein Dist-Upgrade direkt von 16.04 auf 20.04 ist sowieso nicht möglich.

Beim Hoster kommt es drauf an, was du wirklich dort bestellt hast.
Was hast du dort genau?

Bei einen VServer musst du dich um einige Dinge auch mal kümmern.
Dein Hoster sollte dir irgendwelche Upgrade-Wege aufzeigen.
Mag bedeuten: Backup, platt machen, neues Release (dann 20.04 LTS), Restore und alles wieder geradeziehen.

Du hast doch ein Backup, oder?

Ja ein Backup wurde vor kurzem erstellt.

Das hier wieder per Shell im entsprechenden Ordner?
dpkg -l |fgrep php
Sorry, bin jetzt nicht sooo der Experte. :slight_smile:

Hoster check ich gleich mal, was genau wir dort haben.

Damit werden in der Shell (SSH-Sitzung) die Pakete angezeigt, die PHP im Dateinamen haben.
Falls du wenig Ahnung von Linux hast, solltest du vielleicht überlegen dir besser eine gemanagte Nextcloud zu besorgen, wo alle Updates regelmäßig eingespielt und Backups gemacht werden.

Erledigt.
Hier die Pakete Datei von filehorst.de laden
Ich habe Daten in eine txt - Datei gepackt. Für ein Screenshot wäre das ein wenig zu groß.

Wir haben tatsächlich einen Root-Server (M) Heisst mittlerweile anders.
Und ich gebe dir Recht ein Managed System wäre besser. Dann muss ich mich nicht auch noch darum kümmern.

Gruß Stefan

War ja schrecklich der Upload. Auch habe ich mal nur die Pakete aufgeführt: https://pastebin.com/RdDNj3NM

Sieht so aus, dass du nur PHP 7.0 installiert hast und nur für Plesk PHP 7.3.
Aber mit Plesk kenne ich mich leider nicht aus.
Bist du sicher, dass PHP7.3 für Nextcloud genutzt wurde?

Im Plesk System kann man entsprechend die PHP Version wählen. Hier habe ich 7.3 ausgewählt.
Mehr kann man da auch nicht machen. Zumindest wirkt sich das dann auch auf unsere Wordpress Seite aus. Also scheint hier schon mal alles korrekt zu sein.

Das natürlich der Server noch mit PHP 7.0 arbeitet bzw installiert ist wundert mich ein wenig.
Letztes Jahr haben wir ein Upgrade von Hosteurope durchführen lassen, eben auf PHP 7.3.
Das sie alte versionen nicht deinstallieren wundert mich schon.

Ich check mal Plesk ob noch irgendwo was ist…

Danke, ps: nächstes Mal merke ich mir Pastebin :slight_smile:

Schau bitte mal, welches Betriebssytem du nutzt:
uname -a

Das siehst du auch bei

apt-get update
apt-get dist-upgrade

in den Listen. Dort sollte bei Ubuntu 16.04 dann irgendwas mit “Xenial Xerus” stehen.

Probiere auch mal phpinfo aus: https://www.php.net/manual/de/function.phpinfo.php

Dorch die ganzen Rewrites bei Wordpress und Nextcloud musst du evtl. einen eigenen Ordner verwenden, damit die Datei überhaupt korrekt geladen wird.

Linux mail 4.4.0-161-generic #189-Ubuntu SMP Tue Aug 27 08:10:16 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

das habe ich auch gemacht: apt-get update: https://pastebin.com/JvdEGDEX

sowie das hier apt-get dist-upgrade: https://pastebin.com/cFKxkZnK
Habe mich aber nicht getraut /ja zu drücken :slight_smile:

Man sollte sein System schon aktuell halten. Das gilt auch für ein System wie Ubuntu 16.04 LTS. Es gibt immer mal wieder Sicherheitsupdates während des Releases. Aber die Updates bringen dir wahrscheinlich nichts für dein eigentliches Problem. Trotzdem solltest du sie mal einspielen. Du hast hoffentlich ein Backup von allem und weißt, wie du im Notfall wieder alles ans laufen bekommst.

Normale Anwender würden ihr System auf ein neues Release hochziehen. Dafür würde man beim Provider sich einen neuen Server besorgen und alles migrieren.

Leider weiß ich nicht, wie ich dir aktuell helfen kann. Vielleicht kannst du dein Problem mit Nextcloud beheben. Aber eigentlich ist dein System schon fast zu veraltet.

Mich irritiert die Netzwerkanalyse etwas. Da konnte u.a. das Skript login.js nicht geladen werden und in der Spalte “Übertragen” steht “CSP” für jene Skripte.
Wurde vielleicht zuletzt die Content Security Policy (CSP) für den Webserver angepasst? Eventuell wird die Ausführung entscheidender Skripte serverseitig per CSP blockiert.

Danke Devnull. Vermutlich ist es das beste alles neu auzusetzen.

Kannst du abschließend noch schreiben, welches Paket du bei HostEurope verwendest? Was wäre vielleicht noch interessant. Vor allem findest du vielleicht im Internet Upgrade-Wege für dieses Paket.

Konnte seitens Plesk nichts bezgl. CSP finden. In den Einstellungen für Apache kann man ja entsprechend was eintragen. Dies ist nicht der Fall.

Wahrscheinlich serverseitig wie Du schon sagts. Danke

Versuche sicherheitshalber bitte auch noch einen alternativen Browser.


Leider genau das selbe