Kalender in iCal

Welchen Webserver benutzt du? Apache oder nginx?

Ich denke Apache ist nämlich das einzige was ich beim provider in meinem Account finde, habe eben den Support angeschrieben, denke aber es stimmt.

Apache stimmt

okay in die htacess habe ich es auch geschafft aber wo kommen die zwei Zeile:

Redirect 301 /.well-known/carddav/nextcloud/remote.php/dav
Weiterleitung 301 /.well-known/caldav/nextcloud/remote.php/dav

hin? :slight_smile:

Habe sie jetzt unterhalb der Zeile (Dont change anything above this line" gesetzt und gespeichert.

Wenn ich es nun wieder abfrage passiert folgendes, wenn ich es mit Unterverzeichnis aufrufe dann gibts ein Error scheinbar hat dann die Zeile doch geholfen, aber es kommt keine Kennwortabfrage etc…

ABER… jetzt komme ich nciht mehr im Webbrowser in nextcloud rein… gebe ich es mit Unterverzeichnis ein gibts nen Error gebe ich es ohne ein passiert nix.

Oh neee :frowning:

Du hast in beiden Zeilen ein Leerzeichen vergessen, außerdem muss es beidesmal “Redirect” heißen (und nicht “Weiterleitung”). So muss das aussehen, wenn das Unterverzeichnis in dem Nextcloud liegt “nextcloud” heißt

Redirect 301 /.well-known/carddav /nextcloud/remote.php/dav
Redirect 301 /.well-known/caldav /nextcloud/remote.php/dav

Hallo Bernie,

ja die Fehler hatte ich schon gesehen und geändert.

Ich habe diese Zeilen jetzt ganz zum Schluss unter der Zeile “dont change anything above” eingefügt.

Es scheint ja ein Bug in Mac OS X zu sein der seit mehr als 2 Jahren exzistiert und lösbar ist.

Mir ist nur noch nicht ganz klar ob dies die richtige Stelle ist und was ich dann im Account am Mac genau ändern muss. So wie ich die Anleitung verstehe nimmt man statt der langen Pfade nur noch das Hauptverzeichnis? Also z.B. example.com, aber das funktioniert bei mir so nicht.

Eben habe ich nach dem ganzen hin und her das ipad konfiguriert da läuft es nach wie vor flott in beide Richtungen ohne ein Problem.

Kapiere es nicht.

Welche .htaccess hast du denn gehändert? Du musst die im root-Verzeichnis des Webservers ändern. Wenn dort keine .htaccess existiert, muss du sie erstellen und die beiden Zeilen reinschreiben.
Falls du die .htaccess im Nextcloud Unterverzeichnis geändert hast, dann mach die Änderung rückgängig.

Dann mal prüfen, ob die Weiterleitung funktioniert: im Browser https://example.com/.well-known/carddav ansurfen, Benutzername und Kennwort eingeben und dann steht da "This is the webdav interface…"
Gib bitte Bescheid, ob das bei deiner Instanz funktioniert.

EDIT:

Bin mir nicht sicher, ob man von einem Bug sprechen kann, wenn sich Apple an Standards der IETF hält:
https://tools.ietf.org/html/rfc5785
https://tools.ietf.org/html/rfc6764

Hallo Bernie,

ich habe es hinbekommen !!!

Es läuft - YUHUUU!!!

Vielen herzlichen Danke !!!

Ach Mist,

ich habe eine neue NC installiert Unterverzeichnis kryptisch nicht NC.
Und es funzt gar nix mehr.

Dann wieder neu mit Untervezeichnis NC und dann geht es wieder, soll wohl so sein.

Was mir jetzt noch auffällt, wenn ich meine Kontakte online importiere werden dort die Gruppen erkannt und einsortiert, in der Kontakte APP findet diese Sortierung aber nicht statt, dort werden nur “Alle Kontakte” angezeigt keine Gruppen erstellt.

Muss ich diesbzgl. irgendwie nachhelfen?

Viele liebe Grüße! Spritpit

Freut mich, dass es funktioniert :slight_smile:

Apple hat so seine eigene Art Gruppen zu erstellen: Apple erstellt einen neuen Kontakt mit Namen der Gruppe und in diesem Kontakt werden die UUIDs der Gruppenmitglieder gespeichert.

Am Besten erstellst du die Gruppen auf dem Mac, dann sollte das problemlos funktionieren und die Gruppen auch auf die iOS-Geräte übertragen werden.

Hallo Bernie,

wenn ich die Gruppe auf dem Mac erstellen wird sie in Nextcloud nicht als Gruppe sondern als Kontakt angezeigt. Übertrage ich meine Kontakte per Import in Nextcloud wird dort alles richtig angezeigt aber auf dem Mac wird es dann ohne Gruppe angezeigt, einfach nur alle Kontakte.

Erstelle ich eine Gruppe auf dem Mac wird diese auf dem Ipad korrekt angezeigt, aber nicht in der NC.

Gibt es da noch einen Dreh?

Genau so ist es.
Einen Dreh kenne ich nicht. Ist für mich auch nicht so wichtig, denn ich benutze das Adressbuch nur auf den Clients und nicht in Nextcloud.

Hallo Bernie, ja, das funktioniert. “This is the WebDAV interface. It can only be accessed by WebDAV clients such as the Nextcloud desktop sync client.”
Die Kontakte am iphone syncronisieren sich auch, aber den Kalender am Mac kann ich nicht syncronisieren :frowning:
Kannst du mir nochmal helfen?
Viele Grüße
Stefanie

Hallo Stefanie

dass Service Discovery funktioniert ist schon einmal gut :slight_smile:

Unter Mac OS musst du in die Systemeinstellungen gehen und bei Internetaccounts die unterste Option auswählen (“andere” oder so steht da glaube ich - sitze gerade nicht vor dem Mac) und mit dem Plus-Symbol ein neues Konto hinzufügen. Dann caldav-account (nicht caldav-abo!) wählen und dann bei Accounttyp “automatisch” wählen und als Benutzerkonto USERNAME@EXAMPLE.COM angeben.

Dabei gilt:
USERNAME = Nextcloud-Login-Name
EXAMPLE.COM = Domain der Nextcloud-Instanz, und zwar wirklich nur die Domain (ohne weitergehenden Dateipfad, auch wenn Nextcloud in einem Unterordner liegt)

Dann OK drücken und Mac OS holt sich innerhalb von ein paar Minuten die Kalender von Nextcloud und fortan sollten sie synchronisiert werden.

Hallo Bernie,
soweit, so gut - aber leider funzt es irgendwie nicht :frowning:
36
Es steht zwar CalDav da, aber es erscheint kein Kalender. :frowning:

Hallo Bernie,
ich hab den Fehler gefunden - hatte über automatisch keinen Server angegeben und jetzt mit manuell hat es funktioniert. Ich danke dir!
Viele Grüße
Stefanie

da die 14.0.2 das nun nach dem update auch moniert hat im admin-panel,
ich benutze openmandriva 3.0 als Server, hab ich das dann auch bei mir hinzugefügt
Und da ich das über google gefunden hab, knall ich die webapp-config gleich hier rein,
dann findet’s auch jeder … wenn ein Wiki existieren würde, würd’s ich dann im wiki posten.
beim mir funtzt das so… keine meldung mehr im Admin-panel
also hier da :

/etc/httpd/conf/webapps.d/nextcloud.conf

# nextcloud configuration
Alias /nextcloud /srv/nextcloud
<Directory /srv/nextcloud>
    DirectoryIndex index.html index.php
    AllowOverride All
    Options FollowSymlinks
    Require all granted
    Header always set Strict-Transport-Security "max-age=31556926; includeSubDomains; preload"
    Header always set Referrer-Policy "no-referrer"
</Directory>
    Redirect 301 /.well-known/carddav /nextcloud/remote.php/dav
    Redirect 301 /.well-known/caldav /nextcloud/remote.php/dav

Einen dank an Bernie_O :blush: :star::star::star::star::star: von 5

1 Like