Just to make sure I'm doing this as intended

Setup:

My system runs on Proxmox, with Unraid virtualised to handle storage.
My Nextcloud now runs as a VM on Proxmox, instead of a Docker on Unraid, for more control.
The Nextcloud VM Disk is stored on an NFS share from the Unraid VM. I’ve had no problems with this so far.
I’ve put the NC Datadisk on a SMB share from Unraid.

Question:

Is this setup a proper way to run Nextcloud, or am I trying to Frankenstein something together that will come back to bite me in the future? It seems to work fine for the most part, but I sometimes get sync errors from my DAVx on my phone, and the SeedVault backup on my phone. Something like ‘misconfigured server’.
I’m not done yet with the configuration (still need to get a reverse proxy going, for example), but I’d really like to know if I’m on the right track. If there is a smarter or more stable way to set this up, please let me know.

I have a similar setup - proxmox, vm, nas (nfs:data) but I have my vm’s on the local disk and a connected usb and back them up to both usb and nas. usb in case I have to take the vm’s to another system. proxy server set up as I have two other systems to forward to. I found I had to set up my DAVx on the proxy to get it to work. I NC is a snap install.

1 Like

I’ve tried to get it to work on NFS, but I can’t get it to function properly.
I’ve mounted the share in “/var/www/nextcloud/”, but after a while it starts to complain that it can’t create the data directory. The folder I made has www:data as owner. The remote share itself likely isn’t.
fstab entry: 192.168.2.x:‘remote location’ /var/www/nextcloud/folder nfs4 defaults 0 0
"
If I try the ‘ls’ command in the folder, I get the error “ls: cannot open directory ‘.’: Stale file handle”
Am I missing something?

Edit: I found out that the ‘stale file handle’ has to do with Unraid’s mover, so it’s not a nfs version issue.

So to use the NFS share (Linux - nfs-common installed) which you probably already have installed.
I created the share and mounted it in the /mnt folder and then created a link to the /var/www/etc/folder (I normally rename the data folder to _data).
Enter the path to data folder in the config and the external folder option (again I am sure you have already done this).
You then should be able to read/write to folders

1 Like

my fstab: 192.168.x.x:/nfs/share /local/nfs/sharename/ nfs auto,nofail,noatime,nolock,intr,tcp,actimeo=1800 0 0

I do not have the nfs4 as you do but a little bit more it seems - see if this helps!

1 Like