It is impossible to get into nextcloud on the local network

To the router

Hardware Version:
ER605 v2.0
Firmware Version:
2.0.0 Build 20220106 Rel.56391

A PC with Ubuntu 20.24 on board is connected by wire through an unmanaged switch.
The PC is statically assigned an IP and the same IP is reserved for the mac address of this PC on the router side.
Nextcloud is installed and launched on the PC via snap.
The router forwards ports 80 and 443 to the local IP of this PC.
Our external IP is static, dedicated, white, specially rented from the provider.
If we go to a domain that is tied to our external IP, everything works as it should.
But, being on the local network, it is not possible to visit our cloud not by domain or by external IP.
Only by passing through the local IP of our server.

Interestingly, nextcloud previously worked on Windows 10 via Docker with the same router, with the same settings, and everything worked as it should.
It’s also interesting that on the local network the cloud comes off from under the VPN (for example, cloudflare

Do I understand correctly that the problem here can only be in the router?
Or what other options might there be?

That is the correct and expected behavior. The router usually forwards more or less all name resolution requests to the DNS server of your provider on the internet which returns the external ip address which cannot be used/used from your internal network. If you want to use the configured NC DNS name on your LAN too, you have to setup a DNS server which overwrites the DNS resolution over the internet and returns the local ip address for this specific host. You can also try to add a static entry to the /etc/hosts file on your Ubuntu client but it is not guarantied to work.

Now it also seems logical to me that this is how it should work. But before that, there was the same router with the same settings (I raised the cloud that time according to the instructions in the video, but the issue of accessing the cloud from the local network did not even arise.