Issues with Nextcloud 13.0.2, don't show interface


#1
Support intro

Can’t access to my nextcloud after upgrade of system. but i try to do a fresh install the new system and i can’t install the nextcloud.

Nextcloud version 13.0.2:
Operating system and version Fedora 28:
Apache or nginx version Apache 2.4.33:
PHP version 7.2.5-1:

The issue you are facing:

i had that nextcloud version on Fedora 27. The last weekend i updated the system to Fedora 28 using dnf.
When i go to test my nextcloud it showme an error. Ok, we try too many things, like reinstall, remove, downgrade packages, but nothing resolve my issue.

I remember when update the system nextcloud was on maintenance mode.

If i try to do something with the CLI (occ) it show me too many errors too.

Well, i do 2 fresh installs on Fedora 28, with php, apache and mariadb. And i download the nextcloud 13.0.2 version and try to install, but i can’t. Show me “internal server error” too.

What are i doing bad? some bug with any of this versions? or system? This configuration files works on Fedora 27 perfectly.

Please, some help and thanks.

Is this the first time you’ve seen this error? Y:

Steps to replicate it:

  1. Access to my domain of nextcloud
  2. See the error
  3. Error: "Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the webserver log."

The output of your Nextcloud log in Admin > Logging:

I can't access to that site. But nextcloud.log don't show me anything.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => '',
  'passwordsalt' => '',
  'secret' => '',
  'trusted_domains' => 
  array (
    0 => 'domain.ovh',
  ),
  'datadirectory' => '/path/data',
  'overwrite.cli.url' => 'https://domain/',
  'dbtype' => 'mysql',
  'version' => '13.0.2.1',
  'dbname' => 'nubemagna',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '',
  'dbpassword' => '',
  'installed' => true,
  'updater.release.channel' => 'beta',
  'maintenance' => false,
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => 'localhost',
    'port' => 6379,
  ),
  'logfile' => '/path/nextcloud.log',
  'theme' => '',
  'loglevel' => 2,
  'mail_from_address' => 'postmaster',
  'mail_smtpmode' => 'smtp',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_domain' => 'domain.ovh',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'ssl0.ovh.net',
  'mail_smtpport' => '465',
  'mail_smtpsecure' => 'ssl',
  'mail_smtpname' => 'postmaster@domain.ovh',
  'mail_smtppassword' => '',
);

Thanks and regards.


#2

I can confirm this issue on Fedora 28.

I tried a fresh install with both NGINX and Apache. I get an “internal server error” when opening Nextcloud.

A phpfile with phpinfo() shows that php itself is running fine, as is the webserver.

PHP is in version: 7.2.5.-1

I tried the same configuration on Ubuntu, here Nextcloud works.

Thanks for any input!


#3

Hello,

If you install the package of php-json it solve the issue.

Can you confirm?

Regards


#4

Thank you. Can confirm it is working! Thank you!