Issue with old documents after upgrade to 27.0.2


I was running Nextcloud 26, PHP8.1 and with a docker container for the Collabora Nextcloud office and everything worked well.

After upgrading to Nextcloud 27 everything worked well except opening documents like xlsx, docx or odt. The issue is the same always: it asks me to enable javascript (which is already enabled). I must say that if I create a new document everything works well, the problem comes up when I try to open a document that was already in the server.

I did the following trying to solver the issue:

  • Try different browser
  • Upgrade the collabora container to the latest release (previous release that I was using it was from 2 months ago)
  • Upgrade PHP to PHP8.2.9

If I go to the Nextcoud Office tab within administration settings in nextcloud, it only tells me “You have not configured the allow-list for WOPI requests. Without this setting users may download restricted files via WOPI requests to the Nextcloud server”. But this note I wasnt able to solve before but everything worked well before

What else could I do? I attach an screenshot waiting for ideas…


If I duplicate a file (only docs or excel files type) that was in the server as described and I cant open, the new duplicated file I can also open it.

I checked details of both files and there is no difference. It doesnt matter if the files are in my home directory or in a subfolder.

It seems like a permission issue but the fact that only happens with the type of documents opened by Collabora makes me think it is different

I found a bit more information in the apache2 log

It seems I dont have the access granted to the files where that error appears: “Cannot decrypt this file, probably this is a shared file. Please ask the file owner to reshare the file with you.”

I dont know what to do besides make a copy/paste of each docx or xlsx file. I dont understand why this error happened, it is truly annoying.

I hope someone knows a bit about it.


There is already a thread about this issue: Cannot decrypt this file, probably this is a shared file. Please ask the file owner to reshare the file with you

1 Like