Is there a solution RPi Arm64 NC20

and on an x86 cpu, just be sure.

You can also try installing Collabora CODE (arm64) from the appstore. It is in there under office category. Basically it is a packaged version of Collabora that includes some blackmagic for satisfying the reverse proxy requirement. :+1:

it is working on nc20 with communitydocumentserver 0.18

1 Like


i am very sorry, but i tried myself some time ago to install collabora, and was not able to start it.
I now use onlyoffice with the needed app “community document server”. Be aware : Onlyoffice only works with the server app !
But until now, onlyoffice is extremely good !

with greetings,

Christian Anzinger

Thanks Christan, I had a problem doing this. How did you do it ?

I am not using a ready to use image.
I installed nextcloud on a small micro atx board with onboard intel processor an 4 HDDs…
so it is a bit different with a very hard time of trial an error. I recommend to try it yourself.
I bought the linux bible, actual version, a book about ubuntu server 18.04 (When you start now, you should use 20.04) and tried to install, and correct errors reported by nextcloud info under settings. Now my system is without any error and runs in a virtual machine in virtual box under ubuntu 18.04 server. This way i can make copies of the complete nextcloud system. I grew to this over time seperating zoneminder videorecording under linux (one vm) and pihole (another vm) and samba file server (on the main linux server)., You learn a lot, and understand, and its easier to backup the whole systems, and keep them up to date (in case of my server, it runs since 2018, and needs to be completely reinstalled 2022 …)
On a nextcloud without reported errors or correction, you simply activate the apps onlyoffice and the server, and you have the new option in every folder of making a new document …

i hope, you make it, because in images it works … or not …


Christian Anzinger

1 Like

I have a Raspberry Pi 4B with 4 gb using Ubuntu 20.

While version 19 was an easy installation and upgrades were working until version 20, this version required a complete re installation of the MySQL tables as well as Nextcloud (even though the database was backed up). It crashed somewhere in the latter steps of the upgrade process.

While everything is back to normal and working well, I have been working on another Raspberry Pi 4B (4gb) to do the Collabora work.

After the update provided on 10/16, the ARM64 CODE Server is working.

I was just finishing up on setting up a container on a Windows 10 computer. Thankfully I won’t have to complete the installation of the container.

Hi Tim, You have just about mirrored what I have done in the past few weeks and arrived at very similar issues to me. I think the RPi 4 will be great once the range of problems have a workaround or alternative solution but I think that for now at least I will be looking at Ubuntu 20 LTS and implementation of NC onto an Intel NUC or similar to address the inherent problems with both Collabora and OO. Having an integrated/owned at home document server is important for me and having a NC solution without this kind of defies the purpose of NC i.e. I would still be reliant upon other software or web services.

Hancom has been touted as an alternative but doesn’t seem to be available to try yet and may or may not be a viable alternative.

Also, I imagine or hope that nextcloudpi were looking to implement 20 as a build option for pi4 in the near future.


has anyone looked at this odroid device ? dual NAS Pi alternative
dual HDD slots
Amlogic S905X3 SoC

do you think this is strong enough for say 5 users with talk and potentially collabora ?

1 Like

my solution for now is to use ubuntu for pi4 and install it using snap.
sadly kodi doesn’t run as good on ubuntu as on raspbian

I think it will work well, but the limit may be in regards to Collabora. Collabora requires 1gb of ram + 100mb per users (x5), so that will likely by taxing the 4gb of memory available. In general, looks really nice!

NC20 on Pi 4B with 4GB runs with Ubuntu 20 LTS Server 64Bit and Collabora Office with ARM64 Document Server.

The Speed is slow but you can work with it.

Thanks for the update. How slow is it compared to Nextcloud itself?

Nextcloud itself runs good on Pi 4B but you have often pauses on starting/loading documents.
I have seen waitingtimes from 1 to 5 seconds from time to time but since the update from NC19 to NC20 it feels lil bit faster.

If the server connection is done and the document created/loaded, then it is ok.

In one case I have the need to edit simpel word and excel documents, most only one page.
At the place where the Pi 4B works, there is no chance to use a pc or other Intel/AMD Hardware.
The Pi 4B was there for file management and since few weeks, the users wants to edit the documents directly instead of download, edit, upload.

Now they can work in the documents directly and they says that the “low speed” is better than download, edit, upload.

I didn´t test big documents or more users at the same time but I think, you can work with this combination and maybe it will be faster in future, at the moment its only beta (Collabora Document Server (ARM64)).

Sorry for my english …

1 Like

I have onlyoffice docker conatiner that works on Arm64 without any limitations as far as I know… It is emulated, but only the parts that really need to, everything else is modified, so it’s as native as much as it can. On RPI4 4GB I was able to open presentations over 100MB large.

Takes quite a bit of time to build the docker image (ssd would probably help) so make a coffee and sit down while docker does it’s thing. Hope I helped!