iPhone app not syncing photos/videos consistently


I have been using nextcloud (Ubuntu) and the nextcloud app on my iPhone for around a year. All has been good, synching thousands for photos and videos.

The last couple of months however, the app doesn’t seem to upload new photos, it’s as if it doesn’t recognise that there are any new photos to upload.

Have checked that it still has permission to run in the background and I don’t seem to be getting any errors.

Occasionally (every few weeks?) it will notice some photos and upload them.

It used to “see” new photos to upload and process them almost instantly however I now have loads of photos in the camera roll that remain unsynched.

I have trawled forums and GitHub issues and it appears that whilst some other users are reporting issues, that it’s not a widespread enough behaviour to be a known major issue, so I suspect it’s something to do with my set up.

Can anyone point me in the right direction?

Any help would be greatly appreciated.


Nextcloud liquid for iOS
Nextcloud server 27.1.4

Version: 8.1.25

Memory limit: 8 GB

Max execution time: 3600

Upload max size:16 GB

Extensions: Core, date, libxml, openssl, pcre, zlib, bcmath, bz2, ctype, curl, dom, hash, fileinfo, filter, ftp, gd, gmp, json, iconv, intl, SPL, ldap, mbstring, pcntl, PDO, session, posix, Reflection, standard, SimpleXML, mysqlnd, exif, sysvsem, tokenizer, xml, xmlreader, xmlwriter, zip, pdo_mysql, cgi-fcgi, redis, Zend OPcache

Type: mysql

Version: 8.0.35

Size: 450.9 MB

Do you always upload or just with existing wifi connection?

I would try to take a picture, then switch to the app and check if something is uploaded (more → transfer), and on recent you see what has been changed in your Nextcloud recently.
If that doesn’t work, I’d kill the Nextcloud client and start it again.

Hi tflidd thanks for the reply. I’ve just tried this and the app shows no transfers.

I have not restricted uploads to wifi only, and have tried turning the phone’s wifi off and on again, as well as toggling this option in the app itself.

Have killed the app and restarted the phone etc but still no luck!

Any news here? I have the same issue.

Could it be an App problem rather than server?