iOS Talk App won't login, just spins eternally

I’m using Nextcloud with docker, and have my install setup with SSL through LetsEncrypt and a URL. I’ve tried multiple times now to login through the iOS app both from within my Wifi, and from Cellular only, but the app never logs in. The spinner starts and just spins forever.

I can login successfully with the Nextcloud sync apps on desktop, and on my iOS device, and can reach the Nextcloud Web UI through Safari on my iOS Device.

Not sure what’s happening on the Talk app. Is there a log I can check on the server, or something else I might check?

Any help is greatly appreciated.

Hi @Brian_McGonagill :slight_smile:

So if I understand correctly, you set your server url and the spinner next to the input field just spins forever?

Is your server publicly accessible? If so, you could send me an e-mail (ivan [at] nextcloud [dot] com) with your server url and I could take a look at it.

No, I enter the Server URL, then it moves me to the login screen. Next, I enter my credentials for my server, and when I touch the Login button is says logging in, with a spinner, and that’s where it seems to hang with no message of what may have happened.

I’ll email you my URL shortly. Do you need me to create a user for you?

In that case, I would need a test account yes :slight_smile:
So I can check what happen when entenring some valid credentials.

I’ll create them shortly, and email them to you.

I am experiencing the same issue and would be interested in a quick solution as well.

1 Like

Are you using a similar setup to mine?

NextCloud 20 on Docker in my home server. NGinX Proxy Manager pointing my URL to the server, and LetsEncrypt CA Cert for URL with ForceSSL on…

I am using a hetzner hosted NextCloud.

I read the changelog of the iOS App and stumbled over the newly added theme support with the last version as I started using a theme 2 days ago. I already tried deleting and re-installing the app this morning which did not make any difference. Now, after deactivating the theme and re-installing the app it is working normally again.

I guess it’s not the same as my issue, I have no theme installed at all, and am starting from a fresh install of NextCloud.

@ivan I solved my issue after looking through several other posts.

  1. I found that I had to use my NGinX Proxy Manager to forward my traffic to the direct NextCloud App Docker IP, not the general docker0 interface.
  2. I had to add two lines to the config.php
'forcessl' => true,
'overwriteprotocol' =>' https',

I just added those lines to the end, then tried again, and was able to successfully authenticate with my username and password.

Thanks for all your help.

Also, If you are the main dev on the iOS app, could we possibly get the app to use the IOS font size settings, or provide font size settings in the app? My eyes are bad, so really hard to read the messages.

1 Like

Hi @Brian_McGonagill

I’m glad to hear that it’s working now :slight_smile:

Regarding the font size, you are right. The app should calculate the font size depending on user system settings.

I have just opened an issue in the Talk iOS repository.

You can keep track of the feature progress there :wink:

hi @ivan and @Brian_McGonagill i have the exact same problem. But i’m using the android app and my nextcloud instance i installed using snap. I’m using an Apache2 inverse proxy (on other machine) and let’s encrypt SSL certificate. I have already add this lines to the config.php nextcloud file:

‘forcessl’ => true,
‘overwriteprotocol’ =>’ https’,

Now i enter my credentials and goes to the next screen, to grant permission to my phone, i granted and apears a spinner on a white background that spins a little, and then send me back to the server login screen. So still don work :(.

@Brian_McGonagill also mentioned that he re directs traffic of the proxy to the NextCloud App Docker IP, but in my case is necesary? and if it is, how can i do it??


I have the exact same problem, running Nextcloud 23.0.10 on both iOS apps.

I was able to log on the main Nextcloud (sync) app by using the QR code from the desktop.

However, the Talk app refuses to log on, and gets stuck at “Grant Access”.

Nextcloud is sitting behind a proxy, the above parameters have been entered into the config.php file and all else is working fine.