Invalid private key for encryption app. Please update your private key password in your personal settings to recover access to your encrypted files

encryption
nc12
update_problems
#21

NC don’t even blink about this problem. Don’t bother or spend your time. Stick to version 12 better.

NC needs a rolling release schema this update thing is…

1 Like
#22

I have the same problem, but I’m not sure if I had this after upgrade from 13.0.1 to 13.0.2 or after I did some disabling/enabling apps.
At least after disabling Default encryption module, I don’t get that line.
And I have never encrypted any files…

#23

I have this issue, too. After upgrading from 12 to 13 on my old debian installation and after switching to Ubuntu with, of course, a fresh nextcloud installation.
I never used Encryption, too.

#25

Yes, it’s the same here. I have an installation on 13.0.2 without the message and another on 13.0.4 with the message.

I am left with the question, if I backup the 13.0.4 installation and reinstall. Will that solve the problem or do I still have the same situation?

Up until now there has been no encryption used on either installations. So where does this come from?

Verschlüsselung private Key ändern geht nicht
#26

Still have the same problem here too.
Its annoying that no reply from the developers even not a small like, we are searching, we are trying or what ever

#27

I have still not fix this problem at this time. (Nextcloud 13.0.5)
No body have any idea ?

#28

i do not know if this problem is still relevant for some people but:

i had the same error after transfering my nc to an other server and updating it from 13 to 14. i was able to fix the problem by correcting the instance id in the config file. i removed the ‘new’ id and replaced it with the id of my old instance and thats it.

#29

Thank you for the solution.

BUT a very bad attitude from NC for this matter.

#30

This is especially annoying as you cant see the Apps-Buttons below that messages as well - please solve this !!

#31

Same issue. After upgrading from 13 to 14 on my nextcloud pi instance.

#32

OK, I just installed NC Today,
I installed the encryption module, then it prompted me to log out and log back in again,
Then I did and it has the same annoying error message,
I don’t know what’s going on, did someone report a bug?
Where do we report bugs?

#33

I am going to close this topic. The reason is that there are likely many issues regarding the server-side encryption module that might or might not be related. However, it is very hard to follow up on this or reproduce errors.

If you can reproduce a bug on a new setup, it’s probably the best to submit this to the bug tracker https://github.com/nextcloud/server/issues, since the developers have problems in reproducing your errors.

On older systems, the search for errors can be much more painful and hard or impossible to reproduce. I had a lot of troubles myself with this app and I realized that I don’t really need it and the security benefits are very small if you don’t use it on external storage, it was designed for. Now it is even more true when the new client-side-encryption becomes available. If you can afford it, the enterprise subscription might be a way that Nextcloud gets some resources to further investigations in your problem.

closed #34