Internal Server Error when I try to access my instance's web interface

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): Nextcloud 13.0.4
Operating system and version (eg, Ubuntu 17.04): Ubuntu 18.04
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4
PHP version (eg, 7.1): PHP 7.1

The issue you are facing:
So whenever I try to open Nextcloud, I get an internal server error thrown. I have no idea what causes it. I have tried going in via localhost, (the static IP that I have set for the machine running the instance) and the dynamic dns (which I haven’t set up right anyway, so idk why I was trying to go through that.) I’ve tried restarting the system, but it hasn’t worked. I’ve googled round but can’t find anything (hence why I’m creating a new topic) - can anyone make some sense out of these logs please?


Is this the first time you’ve seen this error? (Y/N): No

Steps to replicate it:

  1. Open (the static IP that has been set for the machine hosting the install) in Firefox

Expected Result: Opens to the login screen
Actual Result: Displays the following:

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the webserver log.

The output of your Nextcloud log in /var/snap/nextcloud/common/nextcloud/data:

The output of your config.php file in /var/snap/nextcloud/current/nextcloud/config (make sure you remove any identifiable information!):

The output of your Apache/nginx/system log in /var/snap/nextcloud/current/apache/logs:

for me, this look like your server is missing dependencies and/or is miss-configured.

recheck them using apt-get

a good apache2 install:
apt-get install apache2 apache2-mpm-prefork apache2-prefork-dev libapr1-dev libaprutil1-dev libfcgi-dev libssl-dev zlib1g-dev libcurl4-openssl-dev

tune and check your conf by accessing your http://localhost and by using apache2 -v

optional: php manipulation images software:
apt-get install imagemagick libmagickwand-dev

apt-get install php7.1-fpm php7.1 php7.1-xml php7.1 php7.1-cgi php7.1-cli php7.1-gd php7.1-curl php7.1-zip php7.1-mysql php7.1-mbstring

if mysql use then
apt-get install mysql-server mysql-common libmysqlclient-dev mysql-client

after that, create the mysql user and database

When this is done and working, you can continue with nextcloud and recheck logs ( system log, not nextcloud log as error 500 is apache error an/or subsystem error

1 Like

It shouldn’t be missing dependencies. As you may have picked up from the paths I modified, I installed Nextcloud using the Ubuntu Snap. Also it might be worth saying that I managed to successfully set up and log in before this happened. Any more ideas?

Your config file trusted domains is missing commas after the quote after each element. Make it like the others.


‘trusted_domains’ =>
array (
0 => ‘localhost’,
1 => ‘[REDACTED]’
2 => ‘’
3 => ‘[REDACTED]’

Should be:

‘trusted_domains’ =>
array (
0 => ‘localhost’,
1 => ‘[REDACTED]’,
2 => ‘’,
3 => ‘[REDACTED]’,

That last comma added is optional but not a bad idea in case you add a new one, and don’t remember to add it in for the previous line.

I know some time has passed with this, but I just upgraded a server from Ubuntu 16.04 to 18.04 and we’re seeing the same issue. Were you ever able to solve this?

Ive been strugling with the very same message after an upgrade attempt to latest stable.

1 Like

Such a message can be shown e.g. if your database is down.