Internal Server Error Nextcloud Pi


Nextcloud version (eg, 20.0.5): v1.52.4
Operating system and version (eg, Ubuntu 20.04): Raspbian GNU/Linux 11. 6.1.21-v8+ (aarch64)
PHP version (eg, 7.4): 8.1.21

The issue you are facing:
Hi everyone,
After some time working with the nextcloud pannel i experianced the following problem.
When I try to open my login page it will show an internal server error. The pannel (port 4443) is accessable for me. Nextcloud chack shows an error. I was denied permission to access the nextcloud.log via ssh.
I am quite new with nextcloud and rasberry pi so i dont know mutch about it. Maybie you can help me.
Is this the first time you’ve seen this error? (Y/N):Y

I got the same error i think since about one week now. The information i gathered with the help of the nextcloud trouble shooting guide is:
|NextcloudPi version|v1.52.4|
|NextcloudPi image|NextCloudPi_07-25-22|
|OS|Debian GNU/Linux 11. 5.15.56-v8+ (aarch64)|
|Nextcloud check|error|
|HTTPD service|up|
|PHP service|up|
|MariaDB service|down|
|Redis service|up|
|HPB service|down|
Uptime 78days

‘datadirectory’ => ‘/media/myCloudDrive/ncdata/data’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘’,
‘loglevel’ => ‘2’,
‘log_type’ => ‘file’,
‘htaccess.RewriteBase’ => ‘/’,
‘maintenance’ => false,
‘logfile’ => ‘/media/myCloudDrive/ncdata/data/nextcloud.log’,

The file nextcloud.log can’t be opened. cat nextcloud.log response … input/output error; same for the file neextcloud.log.1

phpinfo() gives same error msg as the home screen

php -v gives: PHP 8.1.10 (cli)

apache2 error.log:
[Wed Aug 09 00:00:01.124956 2023] [ssl:warn] [pid 1248:tid 548087911488] AH01909: localhost:4443:0 server certificate does NOT include an ID which matches the server name
[Wed Aug 09 00:00:01.134198 2023] [mpm_event:notice] [pid 1248:tid 548087911488] AH00489: Apache/2.4.56 (Debian) OpenSSL/1.1.1n configured – resuming normal operations
[Wed Aug 09 00:00:01.134264 2023] [core:notice] [pid 1248:tid 548087911488] AH00094: Command line: ‘/usr/sbin/apache2’

/etc/php/8.0/apache2/php.ini does not exists. directory /etc/php is empty

systemctl status redis-server:
root@nextcloudpi:/# systemctl status redis-server
● redis-server.service - Advanced key-value store
Loaded: loaded (/lib/systemd/system/redis-server.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2023-05-22 11:41:30 CEST; 2 months 18 days ago
Main PID: 2809 (redis-server)
Status: “Ready to accept connections”
Tasks: 5 (limit: 780)
CPU: 14h 53min 51.312s
CGroup: /system.slice/redis-server.service
└─2809 /usr/bin/redis-server

May 22 11:41:30 nextcloudpi systemd[1]: Starting Advanced key-value store…
May 22 11:41:30 nextcloudpi systemd[1]: Started Advanced key-value store.

I think something went wrong during an update. Anyone has a clue what went wrong and how it can be repaired?

Many thanks in advance

Sorry for late reply … the first thing i did was solving the issue … sudo reboot … :roll_eyes: