Internal Server Error - NC 18.0.6, Puppy Linux, XAMPP [SOLVED]

Hello All

My very first post here. :slight_smile:

I’ve installed NC 18.0.4 on Ubuntu successfully in the past. This time I’m doing another install using Puppy Linux - Bionic64 and XAMPP and I’m getting Internal Server Error. I have done the following:

    • Changed ownership using all possible combinations between root, www-data and http
    • I’ve changed write and read permissions to 775

and I’m still getting php error “touch(): Unable to create file /var/www/nextcloud/config/config.php because Permission denied at /var/www/nextcloud/lib/private/Config.php#241”

The only time I was able to get a login screen to complete the setup is when I changed permission to 777, which is unsafe I believe.

I guess my question is what “username” should I use for file/folder ownership? Is there a specific one for XAMPP? I believe I have all the configuration settings right or did I miss anything?

PS: I did not make any changes to nextcloud .htaccess files and thanks in advance.

Solved the problem.

I went ahead and proceed with the final setup by logging in (THE FIRST LOGIN). Of course the ‘overview’ showed me all the things I need to correct. When I opened terminal and entered a command “occ db:convert-filecache-bigint”, it gave me an error saying current user is “www” but the file is owned by “daemon”. And there was my answer. Changed user and group to ‘daemon’ and problem solved.

1 Like