Internal Server Error log file rewritten and then deleted

hi, I just downloaded nextcloud locally and after the first configuration (in which everything was fine), I created a vpn tunnel with zero tier to remotely connect to my cloud, and for the first time I got this error "The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the webserver log. “At the end looking on the internet I solved the problem by setting the parameter” ‘allow_local_remote_servers’ => true, "on the cofig.php file.
I then went back to the internet in localhost and the problem persisted, looking at the log again I got a different error, something inherent to the memory; so I thought it would be a good idea to delete the contents of the log file to clean up and understand myself better … but from that moment on, every time I try to access the file log is not written, so I don’t know what the error is that does not allow me to access , and I don’t know how to fix that nextcloud no longer writes to the log file

What installation procedures did you follow? Be precise, if you want someone knowledgeable to have look, better give them detailed information.
Just downloading Nextcloud locally doesn’t give you a working instance.
So what else did you do to get to a working instance.
Then what exactly did you do to break it?

Is also lacking detail.

Not a good idea at all imho.

Try a fresh install and share logs if you can reproduce the error

1 Like

hello i followed this step by step guide (i know it’s not the correct one since from WSL to PI 4 there is a big difference, but i saw it works (at least the first start worked great).

I will try to delete the entire nextcloud folder and reinstall the zip, then from the guide I will continue to follow step by step from the item “configure nextcloud site”. i want to point out that pretend the nextcloud guide didn’t work and said that the php packages … were missing.
I used the code “sudo apt-get install -y php- {curl, gd, fpm, cli, opcache, mbstring, xml, zip, fileinfo, ldap, intl, bz2, json, imagick, redis, mysql, common}” and it worked.
I have currently installed mariadb version 10.3.31, php version 7.3.31 and apache2 (I don’t know what version).

zerotier one is a service that creates a vpn between 2> devices. I’m not an expert, they just recommended it to me, it works that I install the app on both devices and insert a code that certifies I am the owner of that vpn tunnel. Once the second pc is connected, it creates a connection to the ports of the main device. It will then be the responsibility of the apps to manage the ports (in this case apache2) in practice once the 2 PCs are connected, if on the second I look for “localhost” on the internet, it opens the nextcloud page as if I were using the main PC. (sorry for the nabbo explanation, I’m not an expert, I’ll tell you what I understand).