Internal Server Error after update


I’m using Nextcloud on docker from so at the point of me writing this 17.0.2-ls54.

The Problem I have is the following output on the my nextcloud URL:

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

The Log itself sais Pastebin-text

I may made a mistake along the way with automatic updates (as nextcloud is one of the rare docker-programs that must have the update triggered from within the container).

So I do not exactly know when it happened or what caused it. One day it worked. Less then a week later I did not anymore.

The content of your config.php file is:

$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'datadirectory' => '/data',
  'instanceid' => 'ocf8yhgpv2lw',
  'passwordsalt' => 'supersecred',
  'secret' => 'supersecred2',
  'trusted_domains' => 
  array (
    0 => '',
    1 => '',
    2 => '',
    3 => 'localhost',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'nextcloud',
  'overwrite.cli.url' => '',
  'dbhost' => '',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'oc_admin',
  'dbpassword' => 'supersecred3',
  'installed' => true,
  'theme' => '',
  'maintenance' => false,
  'loglevel' => 2,

The file in /var/log/ngnix/error.log (the only file in there) is empty.

PS: reverting to any former version of the docker-image did not help.

Any solution besides setting it up from scratch would be appreciated (data is safe yet I’d love to keep using the configfiles too).

Can you check if all tables are still present in the DB? The error says your DB is missing tables.
SQLSTATE[42S02]: Base table or view not found: 1932 Table 'nextcloud.oc_appconfig' doesn't exist in engine

You could have DB corruption, lack of space, I don’t know. If you have a decent backup and you don’t care about the cause it might be the easiest to restore the backup.

Thanks for the reply. Unfortunately, it my backup seems to be corrupted to - no idea how that happened.

I also tried to apply this fix with no luck (Couldn't execute 'SELECT /*!40001 SQL_NO_CACHE */ appid, configkey, configvalue FROM oc_appconfig': Lost connection to MySQL server during query (2013)). Seems to be this one file that somehow is wrong.

As I do not have any more backups, I think I have to start from scratch with setting up a new nextcloud db. So I would do:

  1. Wipe existing database-content (keep db-name, passwd etc.) --> can anybody help me with that (mysql nextcloud gets me access denied for root@localhost)
  2. Enter “first-setup”-mode again. --> again pointing the right direction where to look would be helpful.

If you have any better idea on how to get nextcloud working again… Any suggestions are welcome and appreciated.

> mysql --user=user_name --password db_name
Enter password: your_password