Internal Server Error after stabel UPDATE 15.0.7

update_problems
nc15
#1

Update Sucsessfull Finished, but :

# Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@localhost to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Apache/2.4.25 (Debian) Server at ... Port 443


nextcloud.log :

“time”:“2019-04-11T08:06:15+00:00”, ,“user”:"–",“app”:“updater”,“method”:“GET”,“url”:"/core/ajax/update.php? ,“message”:"\OC\Repair::info: Repair info: SCSS cache cleared",
“time”:“2019-04-11T08:06:15+00:00”, ,“user”:"–",“app”:“updater”,“method”:“GET”,“url”:"/core/ajax/update.php? ,“message”:"\OC\Repair::info: Repair info: JS cache cleared",
“time”:“2019-04-11T08:06:15+00:00”, ,“user”:"–",“app”:“updater”,“method”:“GET”,“url”:"/core/ajax/update.php? ,“message”:"\OC\Repair::step: Repair step: Clear every generated avatar on major updates",
“time”:“2019-04-11T08:06:15+00:00”, ,“user”:"–",“app”:“updater”,“method”:“GET”,“url”:"/core/ajax/update.php? ,“message”:"\OC\Repair::step: Repair step: Add preview background cleanup job",
“time”:“2019-04-11T08:06:15+00:00”, ,“user”:"–",“app”:“updater”,“method”:“GET”,“url”:"/core/ajax/update.php? ,“message”:"\OC\Repair::step: Repair step: Queue a one-time job to cleanup old backups of the updater",
“time”:“2019-04-11T08:06:15+00:00”, ,“user”:"–",“app”:“updater”,“method”:“GET”,“url”:"/core/ajax/update.php? ,“message”:"\OC\Repair::step: Repair step: Repair pending cron jobs",
“time”:“2019-04-11T08:06:15+00:00”, ,“user”:"–",“app”:“updater”,“method”:“GET”,“url”:"/core/ajax/update.php?,“message”:"\OC\Repair::info: Repair info: No need to repair pending cron jobs.",
“time”:“2019-04-11T08:06:15+00:00”, ,“user”:"–",“app”:“updater”,“method”:“GET”,“url”:"/core/ajax/update.php?,“message”:"\OC\Repair::step: Repair step: Extract the vcard uid and store it in the db",
“time”:“2019-04-11T08:06:15+00:00”, ,“user”:"–",“app”:“updater”,“method”:“GET”,“url”:"/core/ajax/update.php? ,“message”:"\OC\Updater::startCheckCodeIntegrity: Starting code integrity check…",
“time”:“2019-04-11T08:06:19+00:00”, ,“user”:"–",“app”:“updater”,“method”:“GET”,“url”:"/core/ajax/update.php?,“message”:"\OC\Updater::finishedCheckCodeIntegrity: Finished code integrity check"
“time”:“2019-04-11T08:06:19+00:00”, ,“user”:"–",“app”:“updater”,“method”:“GET”,“url”:"/core/ajax/update.php?“message”:"\OC\Updater::updateEnd: Update successful"
“time”:“2019-04-11T08:06:19+00:00”,“user”:"–",“app”:“updater”,“method”:“GET”,“url”:"/core/ajax/update.php?,“message”:"\OC\Updater::maintenanceDisabled: Turned off maintenance mode"
“time”:“2019-04-11T08:06:19+00:00”,“user”:"–",“app”:“updater”,“method”:“GET”,“url”:"/core/ajax/update.php?requesttoken=TJ0%3D",“message”:"\OC\Updater::resetLogLevel: Reset log level to Warning(2)"

File: /var/log/apache2/error.log

[Fri Apr 12 00:06:43.999835 2019] [mpm_prefork:notice] [pid 26018] AH00163: Apache/2.4.25 (Debian) OpenSSL/1.0.2r configured – resuming normal oper$
[Fri Apr 12 00:06:43.999900 2019] [core:notice] [pid 26018] AH00094: Command line: ‘/usr/sbin/apache2’
[Fri Apr 12 08:22:01.552086 2019] [core:error] [pid 728] [client 10.10.9.172:61567] AH00124: Request exceeded the limit of 10 internal redirects due$
[Fri Apr 12 08:22:01.614793 2019] [core:info] [pid 730] [client 10.10.9.172:61570] AH00128: File does not exist: /var/www/html/nextcloud/favicon.ico$
$ts due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace.

Can someone help me fix this?

#2

I’ve had problems after updates and after system reboot.
My mysql-password seems to be the problem.

I run Raspberry Pi3 and Raspbian Stretch
-Apache 2.4
-MariaDB
-PHP7.3
-Nextcloud 15.0.5.3 and NextcloudPi 1.10.0.

By opening the nextcloud config file (/var/www/nextcloud/config/config.php) and changing the password from encrypted format to plain text password (‘dbpassword’ => ‘aldsgjlasögkjasödlgkjsdagölk’,) my system started working again.

Config file shoud be readable only for www-data group, so no other “regular” users should be able to see the password even it’s in plain text format in config file.

I have to do this after each system reboot. Haven’t been able to change this. Hope this helps. :slight_smile:

#3

Hi norppa

with me is already dbpassword=> plain text!!!
but not working! :confused:

#4

#5

mysql/mariadb is working ok?

#6

Check your .htaccess in your nextcloud directory and try to remove everything under

DO NOT CHANGE ANYTHING ABOVE THIS LINE

You can keep

ErrorDocument 403 //
ErrorDocument 404 //

Backup your file first. Restart your webserver after that change (just in case)

#7

Yessssssss :smiley:

/var/www/html/nextcloud/.htaccess

RewriteBase /nextcloud/ changed too -> RewriteBase /

Nextcloud is working!!!

THX Mysterycz

#8

I have just installed Nextcloud 15.0.7 server for the 1st time (not an upgrade). After installation, I get Internal Server error when invoking http://localhost/nextcloud/index.php.

  • I have checked .htaccess for things reported in the earlier messages. Some of them don’t apply to the new installation.
  • Apache is running on port 8080.
  • Mysql is up and running.
  • I have left the config as standard and not made any changes.

What else do I have do to get this to work?

Thanks.

Marty

An hour later… I got it working. Thought this might help others.

If you have completed a new install and on starting up nextcloud, you get an Internal Server error, complete your install by running this on the command line to set all nextcloud file permissions recursively to 755:

chown -R www-data:www-data /var/www/html/nextcloud

This should get you moving.

Cheers,

Marty