Internal Server error after modify LDAP / AD integration

Dear Nextcloud team,

I got an error with Internal Server Error after i change some option on Setting >> LDAP / AD integration

Here is an error:


Internal Server Error

The server was unable to complete your request.

If this happens again, please send the technical details below to the server administrator.

More details can be found in the server log.

Technical details

  • Remote Address: x.x.x.x
  • Request ID: mG8yphzLZMDZhfNRA9eo

Please help me to check this issue.

Best Regards,
Kimseng

-> Check the Nextcloud log file.

Here is Quotation:

{“reqId”:“waefh6fc4cS6TRPGAFAd”,“level”:4,“time”:“2020-12-04T11:10:51+00:00”,“remoteAddr”:“x.x.x.x”,“user”:“97409E2D-4754-4338-B98A-78C05D9929C5”,“app”:“webdav”,“method”:“PROPFIND”,“url”:"/remote.php/dav/files/97409E2D-4754-4338-B98A-78C05D9929C5/NOC-U2",“message”:{“Exception”:“Sabre\DAV\Exception\ServiceUnavailable”,“Message”:“Exception: LDAP Operations error”,“Code”:0,“Trace”:[{“file”:"/var/www/html/3rdparty/sabre/event/lib/WildcardEmitterTrait.php",“line”:89,“function”:"{closure}",“args”:["*** sensitive parameters replaced ***"]},{“file”:"/var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php",“line”:458,“function”:“emit”,“class”:“Sabre\DAV\Server”,“type”:"->"},{“file”:"/var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php",“line”:251,“function”:“invokeMethod”,“class”:“Sabre\DAV\Server”,“type”:"->"},{“file”:"/var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php",“line”:319,“function”:“start”,“class”:“Sabre\DAV\Server”,“type”:"->"},{“file”:"/var/www/html/remote.php",“line”:76,“function”:“exec”,“class”:“Sabre\DAV\Server”,“type”:"->"},{“file”:"/var/www/html/remote.php",“line”:169,“function”:“handleException”}],“File”:"/var/www/html/remote.php",“Line”:74,“CustomMessage”:"–"},“userAgent”:“Mozilla/5.0 (Windows) mirall/3.0.3stable-Win64 (build 20201029) (Nextcloud)”,“version”:“20.0.2.2”}

I would interpret the message as if no connection to the LDAP server can be established and/or a LDAP query error appeared?!

First my LDAP is working fine but i have some problem with slow login and then i try to change some LDAP configure to the wrong parameter then i got Internal Server Error.

Can you revert the change so that it is working again? It might be a good idea to post the working and not working LDAP configuration so that other users can give you a hint what need to be changed.

Yes i want to go change back but when i go to setting for rollback configuration is show

======================

Internal Server Error

The server was unable to complete your request.

If this happens again, please send the technical details below to the server administrator.

More details can be found in the server log.

Technical details

  • Remote Address: x.x.x.x
  • Request ID: mG8yphzLZMDZhfNRA9eo

=====================

Please let me know how to change on CLI?

Best Regards,
Kimseng