Integrity check failed and app settings page blank

Hi,

today Ive updated nextcloud from 16.0.1 to 16.0.3. I can access the webinterface of nextcloud and the device are synching but the intergrity check didnt pass and I can access the website for the settings of the apps https://xxx.ddnss.org/settings/apps :confused:

The page is blank.

Results

  • core
    • INVALID_HASH
      • .user.ini

Raw output

Array
(
[core] => Array
(
[INVALID_HASH] => Array
(
[.user.ini] => Array
(
[expected] => 4843b3217e91f8536cb9b52700efb20300290292cf6286f92794d4cec99df286afeb7dd6c91b1be20bc55eda541eef230a5c5e7dcd46c189edd0ed1e80c6d3f5
[current] => 3fadb60f97666a1f66cf5ef4a4b4944f9326f6c7e6c2eae8b8b7f0a7ece705c67a99624c6ea56e4a6526ea9ac5611563b0df56b093c6f5f48c1ee2ff560d54cc
)

            )

    )

)

Operating system: Linux 4.15.0-54-generic #58-Ubuntu SMP Mon Jun 24 10:55:24 UTC 2019 x86_64

Webserver: Apache/2.4.29 (Ubuntu) (fpm-fcgi)

Database: pgsql PostgreSQL 10.9 (Ubuntu 10.9-0ubuntu0.18.04.1) on x86_64-pc-linux-gnu, compiled by gcc (Ubuntu 7.4.0-1ubuntu1~18.04.1) 7.4.0, 64-bit

PHP version: 7.2.19-0ubuntu0.18.04.1

Modules loaded: Core, date, libxml, openssl, pcre, zlib, filter, hash, Reflection, SPL, sodium, session, standard, cgi-fcgi, json, PDO, xml, bz2, calendar, ctype, curl, dom, mbstring, fileinfo, ftp, gd, gettext, gmp, iconv, imagick, imap, intl, redis, ldap, exif, pdo_pgsql, pgsql, Phar, posix, readline, shmop, SimpleXML, smbclient, soap, sockets, sysvmsg, sysvsem, sysvshm, tokenizer, wddx, xmlreader, xmlwriter, xsl, zip, libsmbclient, Zend OPcache

Ive attached a screesnhot of the.user.ini.
For me it looks like a .htaccess file!?

When Ive upgrade from 16.0 to 16.0.1 there was no issue.

Ive googled for this problem but I didnt find any solution for my problem.

Can anybody give me hint how to fix this problem?

Greetings
X_Burner

Integrity check failed: Compare the .user.ini file with the one shipped with the Nextcloud 16.0.3 package. Most likely the files differ which is causing the warning.

App settings page blank: This problem has first been reported in this forum with Nextcloud 16.0.2. Make sure that you empty your browser cache once before you access Nextcloud. This should solve the problem.

Hi j-ed,
the files differ totally. Ive replaced the content of my .user.ini with the one from the package but the integrity check still didnt pass :frowning:

From the package:
mbstring.func_overload=0
always_populate_raw_post_data=-1
default_charset=โ€˜UTF-8โ€™
output_buffering=0

My:



SetEnvIfNoCase ^Authorization$ โ€œ(.+)โ€ XAUTHORIZATION=$1
RequestHeader set XAuthorization %{XAUTHORIZATION}e env=XAUTHORIZATION


SetEnvIfNoCase Authorization โ€œ(.+)โ€ HTTP_AUTHORIZATION=$1

# Add security and privacy related headers Header set X-Content-Type-Options "nosniff" Header set X-XSS-Protection "1; mode=block" Header set X-Robots-Tag "none" Header set X-Download-Options "noopen" Header set X-Permitted-Cross-Domain-Policies "none" Header set Referrer-Policy "no-referrer" SetEnv modHeadersAvailable true

Add cache control for static resources

<FilesMatch โ€œ.(css|js|svg|gif)$โ€>
Header set Cache-Control โ€œmax-age=15778463โ€

Let browsers cache WOFF files for a week

<FilesMatch โ€œ.woff2?$โ€>
Header set Cache-Control โ€œmax-age=604800โ€



php_value mbstring.func_overload 0
php_value default_charset โ€˜UTF-8โ€™
php_value output_buffering 0

SetEnv htaccessWorking true



RewriteEngine on
RewriteCond %{HTTP_USER_AGENT} DavClnt
RewriteRule ^$ /remote.php/webdav/ [L,R=302]
RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteRule ^.well-known/host-meta /public.php?service=host-meta [QSA,L]
RewriteRule ^.well-known/host-meta.json /public.php?service=host-meta-json [QSA,L]
RewriteRule ^.well-known/webfinger /public.php?service=webfinger [QSA,L]
RewriteRule ^.well-known/carddav /remote.php/dav/ [R=301,L]
RewriteRule ^.well-known/caldav /remote.php/dav/ [R=301,L]
RewriteRule ^remote/(.) remote.php [QSA,L]
RewriteRule ^(?:build|tests|config|lib|3rdparty|templates)/.
- [R=404,L]
RewriteCond %{REQUEST_URI} !^/.well-known/(acme-challenge|pki-validation)/.*
RewriteRule ^(?:.|autotest|occ|issue|indie|db_|console).* - [R=404,L]


AddType image/svg+xml svg svgz
AddEncoding gzip svgz


DirectoryIndex index.php index.html

AddDefaultCharset utf-8
Options -Indexes

ModPagespeed Off

DO NOT CHANGE ANYTHING ABOVE THIS LINE

ErrorDocument 403 /
ErrorDocument 404 /

Options -MultiViews
RewriteRule ^core/js/oc.js$ index.php [PT,E=PATH_INFO:$1]
RewriteRule ^core/preview.png$ index.php [PT,E=PATH_INFO:$1]
RewriteCond %{REQUEST_FILENAME} !.(css|js|svg|gif|png|html|ttf|woff2?|ico|jpg|jpeg)$
RewriteCond %{REQUEST_FILENAME} !core/img/favicon.ico$
RewriteCond %{REQUEST_FILENAME} !core/img/manifest.json$
RewriteCond %{REQUEST_FILENAME} !/remote.php
RewriteCond %{REQUEST_FILENAME} !/public.php
RewriteCond %{REQUEST_FILENAME} !/cron.php
RewriteCond %{REQUEST_FILENAME} !/core/ajax/update.php
RewriteCond %{REQUEST_FILENAME} !/status.php
RewriteCond %{REQUEST_FILENAME} !/ocs/v1.php
RewriteCond %{REQUEST_FILENAME} !/ocs/v2.php
RewriteCond %{REQUEST_FILENAME} !/robots.txt
RewriteCond %{REQUEST_FILENAME} !/updater/
RewriteCond %{REQUEST_FILENAME} !/ocs-provider/
RewriteCond %{REQUEST_FILENAME} !/ocm-provider/
RewriteCond %{REQUEST_URI} !^/.well-known/(acme-challenge|pki-validation)/.*
RewriteRule . index.php [PT,E=PATH_INFO:$1]
RewriteBase /

SetEnv front_controller_active true

DirectorySlash off


Thanks for the hint with the cache :wink:

X_Burner

I can definitely confirm that the .user.ini file checksum, of the Nextcloud 16.0.3 archive has exactly the requested checksum on my system. So I donโ€™t know which package youโ€™ve used to extract the file.

# ls -al .user.ini
-rw-r----- 1 wwwrun nogroup 101 Jul  9 13:59 .user.ini

# sha512sum .user.ini
4843b3217e91f8536cb9b52700efb20300290292cf6286f92794d4cec99df286afeb7dd6c91b1be20bc55eda541eef230a5c5e7dcd46c189edd0ed1e80c6d3f5  .user.ini

Ive downloaded the server package at nextcloud.
Can you send me Mail (X_Burner@web.de) with โ€žyourโ€œ user.ini?
Or attach it here?