Integration with iOS file explorer after recent [28 Oct 2019] update (iPadOS 13.2)

After updating the iPad with the recent [28 Oct 2019] update (iPadOS 13.2). The nextcloud is not operating as before. If I want to modify a file, I cannot open it in other applications (“Open in” option disappears), I should first copy somewhere else and modify the copied version. For example, I can see the PDF in nextcloud, but I cannot “open in” in any of PDF readers (I tried PDF Expert and Acrobat reader), but can only copy it (e.g. with option “Copy to” PDF Expert). This is not the case with other cloud services I tried (which used to work in this way). I guess in the new iPadOS the integration of nextcloud with the native file explorer needs to be updated.

I was wondering if other people also face with this issue and find a way to solve it?


I have the same problem. With the iPhone it works perfectly fine and I can choose “open in” in the nextcloud app or directly open the file from another app. In iPad this option does not exist.

1 Like

same problem


Me too. Cant save PDFs from iOS Mail to Nextcloud.


Hi, I think I got the same problem with my Nextcloud 17.0.1-0 and the version 16 before that.
iPhone (iOS 13.3) and iPad Air (iOS 12…) show the same behaviour

When I try to open nextcloud within the Files App it just stays blank and shows no contents.

When I try to save a file from another app to nextcloud it begins to upload, when the “progress circle” is full, it looks like it begins to upload again, then I get an long error message with an http error 401 in it.
Uploading files from within the nextcloud app (e.g. photos or video) works fine. Automatic Photo ipload also seems to work fine.

Any ideas how to troubleshoot this? :no_mouth:

kind regards

1 Like