Integrating OnlyOffice App - Bad Request or Timeout Error

I have set-up two headless VM servers on the same virtualbox host, one as Nextcloud cloud server and another as a OnlyOffice Document server.

I am familiar with the Nextcloud installation and this is a typical default installation. I followed the recommended guide: for a docker OO installation.

I am using custom DNS (by editing /etc/hosts) on the same “bridged” LAN and I can ping the the OO server from the NC server and vice versa. All firewalls are disabled. Yet I am getting a Timeout Error:

Any help would be appreciated.

What do you see, when you access http://documentserver/ in your browser (with hosts resolving to correct server)? Does it show: “Running”?
While Ping only shows that the hardware/ virtual server is reachable, you need to check if the webserver is running and reachable (from the network).

I do not see the any “Running” notification, but I get this:

Then I can login and use my document server, however I would like to integrate into my own Nextcloud Cloud server running on another VM. This is how I understood the app guide.

Hi, you are obviously accessing your nextcloud server when entering http://documentserver/.

If you installed onlyoffice for owncloud/ nextcloud, the page for the onlyoffice server should look like this:

I mean you wrote that you created two separate virtual servers, one is running only Nextcloud and the other is running only Onlyoffice, right? So there is actually no way, that the login screen for Onlyoffice is identical to the login screen for Onlyoffice (with the document server version of Onlyoffice there is no login page at all).

It seems http://documentserver/ resolves to the wrong IP address.

Thank you for the hint but that is obviously not the case:

  1. I use the same username but different passwords for the Cloud Server and the Document Server.
  2. I verified my /etc/hosts entries and they are consistent on all my machines:

$ grep -v ‘^#’ /etc/hosts | grep server documentserver cloudserver

  1. I can even demonstrate that I may edit OnlyOffice documents on my Document Server but not on my Cloud Server:

I conclude that the OnlyOffice docker installation is for a complete Cloud Server that includes OnlyOffice Document Server. However I require to install an Office app on my existing Nextcloud Cloud Server.


Please try to enter not only the public address of the document server, as it is shown on your first screenshot, but also internal address of the document server ( and the internal address of NextCloud ( Click the “Advanced server settings” to open additional address settings.


Both servers have populated /etc/hosts but I followed your advice to enter IP addresses but there may be a problem because the internal address of my NC Cloud Server is

I understood that I need to enter these on the NC Cloud Server Admin. I tried all combinations but none of them worked.

Accessing the servers from the IP addresses was added as a trusted domain.



Your setup is not really clear. When correctly resolves to documentserver and correctly resolves to cloudserver

and additionally you can login on your Document server (with the Nextcloud login screen) and edit Onlyoffice documents

… then you actually have two Nextcloud installations;

  • one with Onlyoffice installed and working
  • another one without Onlyoffice

First of all you should be aware that a server provides services (like a webserver) on specific ports. A webserver runs on port 80 (http) or 443 (https) default and a database will run on port 1521 for example. While only one service can run on a single port, you need to define another port for a second web service for example. Nextcloud AND Onlyoffice are both web services and due to the fact that you see the Nextcloud login screen, when you access the document server, the web service Nextcloud is running on port 80 / 443. This means: Onlyoffice is running on a different port!
Therefor, when you want to use Onlyoffice from another server - like your other cloudserver - you need to define the correct port in the admin section.

So for “Document Editing Service Address” you need to enter http://documentserver:9980 for example. You need to check the correct port first, of course. Actually you should be able to copy the port (the number behind “:” ) in the same admin section from the Nextcloud server which has Onlyoffice running.

Three things you could do then:

  1. use the second Nextcloud installation as a test system for Nextcloud and only the Onlyoffice service is productive for your primary Nextcloud server
  2. uninstall Nextcloud on the document server, while you only use the primary cloudserver as your main NC anyways
  3. if you want to run Onlyoffice and Nextcloud on one server, repeat the same steps on the cloudserver that you did on the documentserver - it obviously worked well there :wink:

I think that you made a clever point but I am still not sure how correct that is:

From the documentserver I see this

chris@documentserver:~$ sudo netstat -anutp
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp6 0 0 :::80 :::* LISTEN 1283/docker-proxy
tcp6 0 0 :::443 :::* LISTEN 1256/docker-proxy
udp 0 0* 1009/ntpd
udp 0 0* 1009/ntpd
udp 0 0* 1009/ntpd
udp 0 0* 1009/ntpd
udp6 0 0 fe80::f88e:15ff:fec:123 :::* 1009/ntpd
udp6 0 0 fe80::d012:e6ff:fe9:123 :::* 1009/ntpd
udp6 0 0 fe80::bcb3:ffff:fe4:123 :::* 1009/ntpd
udp6 0 0 fe80::42:79ff:feac::123 :::* 1009/ntpd
udp6 0 0 fe80::a00:27ff:fe52:123 :::* 1009/ntpd
udp6 0 0 ::1:123 :::* 1009/ntpd
udp6 0 0 :::123 :::* 1009/ntpd

On, I found nothing.

From the cloudserver I see this:

chris@cloudserver:~$ nmap documentserver

Starting Nmap 7.12 ( ) at 2017-11-09 20:32 CET
Nmap scan report for documentserver (
Host is up (0.015s latency).
rDNS record for
Not shown: 998 closed ports
80/tcp open http

Nmap done: 1 IP address (1 host up) scanned in 0.44 seconds

And here is a screenshot of my Admin page of the Documentserver.

As for your suggestions, I already have a production an https NextCloud server (alongside with mariadb and php-redis) that I rely on for backing up. I thought I should try and install a good Office app but it is not essential. I might try the other (non-docker) installation next.

Now it works. This is the setting that I deployed on a non-docker OnlyOffice document server installation:

A screenshot of the “thing” at work:

Thanks to all that helped.