Instance over a secure connection, however your instance is generating insecure URLs

My setup is a Pi 4 with OMV, Nextcloud, jellyfin, hassio run with caddy and cloudflare for https, I have all links are running in https secured but nextcloud security scan shows the below errors although i followed the documents but it does actually provide that config.php is not properly configured
[/details]

Nextcloud version (eg, 20.0.5): 23.0.2
Operating system and version (eg, Ubuntu 20.04): Raspbian GNU/Linux 11 (bullseye)
Apache or nginx version (eg, Apache 2.4.25): 2.4.52
PHP version (eg, 7.4): 8.0.1

The issue you are facing:

  • You are accessing your instance over a secure connection, however your instance is generating insecure URLs. This most likely means that you are behind a reverse proxy and the overwrite config variables are not set correctly. Please read the documentation page about this :arrow_upper_right:.

Is this the first time you’ve seen this error? (Y/N): Y (New setup)

Steps to replicate it:

  1. added the below with write ip and domain name
'trusted_proxies'   => ['192.168.1.110'],
  'overwritehost'     => 'ssl-proxy.tld',
  'overwriteprotocol' => 'https',
  'overwritewebroot'  => '/cloud.domainname',
  'overwritecondaddr' => '^192\.168\.1\.110$',

The output of your Nextcloud log in Admin > Logging:

not sure where to find this please glet me know where

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

config/config.php (https://pastebin.com/kbS6Eq2h)

Would appreciate some advice here

The error has a link to the fix. Most likely the setting you need is overwriteprotocol.

The fix links to a dead link. This appears to be a recurring issue with NextCloud documentation. More detail required, here.