Installing on hosted webspace

Is this still supported/possible?

Cannot say anything about the support, but I successfully installed NC 9 on shared hosting just recently. No problems whatsoever.

Nothing is preventing NC from being installed in a shared environment, as long as the required components are available and I haven’t seen anything on the roadmap that will indicate that this will change in the near future.

I had issues in installing OC 9 on my webhosting. And could not find out the reason why it would not install

You will probably see some error/warning messages in the Admin page. Most of these can probably be fixed and there is a good chance that someone will already have published a workaround – Google the messages.

For example, installing older versions (ownCloud) on OVH shared hosting, all the messages can be fixed with various file edits, except the ‘getenv(“PATH”)’ warning, which doesn’t prevent correct working. I haven’t yet migrated to Nextcloud, but I expect that the file integrity check will have to be disabled in order to allow the necessary file edits.

Which hosting service? Did you have any error messages?

1 Like


Question for you: Could you kindly provide a few more details on your installation? For example:

  • If you installed NC 9 on Shared Hosting, what kind of Panel Software is your provider using? cPanel, Plesk, etc?

  • If you are a normal shared hosting user, how exactly did you install NC and have it stay contained within your cPanel account (that is if you are using cPanel)?

  • Did you SSH into your own cPanel account via command-line, then install everything through CLI?

Thank you,


@Joe: Sure, sorry for not having done so right away in the first place…

My Webhoster offers a software-installer (to the best of my knowledge: other than cpanel or plesk) for packaged and already configured software, but I didn’t use it

I downloaded and extracted the tarball / tgz package to a dedicated directory using (Web-)FTP, setup a a MYSQL database and ran the installer (through browser) to provide the configuration details. No need for ssh / cli altogether.

It really was straight forward, which makes me think, that I probably wasn’t too much of help for you now… in that case sorry :wink:


This is awesome, thank you!


thanx for feedback, will give it another try in some days.
I’m shure the problems are at the webserver and the configuration, btw the log is not very useful
just a http 500 error

Just a very long shot, that might be completely unrelated an utter bullsh#t…

The only time I encountered a 500 error during configuration of a Cloud Software was when php value allow_url_include was disabled.

Why not try that? Use .htaccess to set
php_admin_flag allow_url_include on


Thanx John
the tip with the php_admin_flag was the right one…
it was turned off in the php.ini
so it worked…

Also, be sure to check the logs (Apache/Nginx/ownCloud.log) for suspicious sounding error messages.


I have been trying to install NC v9.0.53 on hosted webspace as well. I still have the HTTP 500 problem although I have the allow_url_include on.

I can see the setup page where I need to create the admin account however after I fill everything and click ‘Finish Setup’ I see the HTTP 500 error.

The log file under nextcloud/data/owncloud.log says the following:

“app”:“mysql.setup”,“message”:“Specific user creation failed: An exception occurred while executing ‘SELECT user FROM mysql.user WHERE user=?’ with params [“oc_admin”]:\n\nSQLSTATE[42000]: Syntax error or access violation: 1142 SELECT command denied to user ‘or_nxuser’@‘localhost’ for table ‘user’”,“level”:3,“time”:“2016-08-03T06:57:49+00:00”,“method”:“POST”,“url”:"/nextcloud/index.php"

“app”:“mysql.setup”,“message”:“Database creation failed: An exception occurred while executing ‘GRANT ALL PRIVILEGES ON or_nxcloud . * TO ‘or_nxuser’’:\n\nSQLSTATE[42000]: Syntax error or access violation: 1044 Access denied for user ‘or_nxuser’@‘localhost’ to database ‘or_nxcloud’”,“level”:3,“time”:“2016-08-03T06:57:49+00:00”,“method”:“POST”,“url”:"/nextcloud/index.php"

However I can see from cPanel that or_nxuser has all the rights over or_nxcloud!

I can also see that the admin user is created. (i.e: There is a folder created under /nextcloud/data with the user name) I even see that the database is created and it has entries including the admin user under the users field.

Has anyone encountered this problem or any idea what the cause might be?

as long as they don’t use nginx apache proxy setup should be fine have installed on a few shared hosts for people

Thank you dmacleo. I try to install for eHosts. They don’t use NGINX but I still have the same error. If you did install for eHosts, do you recall making any special setup?

never used them so no idea, sorry

My php version was 5.6, I changed to php 7 and increased the memory_limit to 256MB in php.ini because I realized that there was the error.log saying PHP out of memory.

Everything is solved now.

Happy you got it solved. Thanks for reporting back!

I am also struggling on shared host. I have setup nextcloud to my …www/nextcloud folder. I can access it
from browser. But when I try to setup nextcloud it says ‘cant create or write into the data
directory’. Does someone has any clue?

Webhosting environments can be very different. Please open a new topic with detailed information about your problem. Closing here to prevent further hijacking.