Installing Nextcloud AIO on raspberry pi behing Nginx proxy manager

I am fan of Nextcloud since the day I knew it.
Recently I had to download and install Nextcloud on my Raspberry again. (because the old docker compose that I had did not work any more. and it is not my issue. now).
My issue is, I have installed the docker behind the Reverse proxy version.
everything is installed but I still can not run the service.
here is the docker command that I have ran:

sudo docker run \
--sig-proxy=false \
--name nextcloud-aio-mastercontainer \
--restart always \
--publish 8080:8080 \
--env APACHE_PORT=11000 \
--volume nextcloud_aio_mastercontainer:/mnt/docker-aio-config \
--volume /var/run/docker.sock:/var/run/docker.sock:ro \

Cloudflare proxy is off.

I have installed two SSL certificates today.
here is how my Nginx Proxy manager looks like

here is logs of nextcloud AIO:

Trying to fix docker.sock permissions internally...
Creating docker group internally with id 121
e[0;92mInitial startup of Nextcloud All-in-One complete!
You should be able to open the Nextcloud AIO Interface now on port 8080 of this server!
E.g. https://internal.ip.of.this.server:8080

If your server has port 80 and 8443 open and you point a domain to your server, you can get a valid certificate automatically by opening the Nextcloud AIO Interface via:
{"level":"info","ts":1688320093.5765917,"msg":"using provided configuration","config_file":"/Caddyfile","config_adapter":""}
[Sun Jul 02 17:48:13.578943 2023] [mpm_event:notice] [pid 111:tid 281473818509408] AH00489: Apache/2.4.57 (Unix) OpenSSL/3.1.1 configured -- resuming normal operations
[Sun Jul 02 17:48:13.580763 2023] [core:notice] [pid 111:tid 281473818509408] AH00094: Command line: 'httpd -D FOREGROUND'
[02-Jul-2023 17:48:13] NOTICE: fpm is running, pid 115
[02-Jul-2023 17:48:13] NOTICE: ready to handle connections

here is Apache logs:

{"level":"info","ts":1688324275.2452369,"msg":"using provided configuration","config_file":"/Caddyfile","config_adapter":""}
[Sun Jul 02 18:57:55.267985 2023] [mpm_event:notice] [pid 127:tid 281473783767136] AH00489: Apache/2.4.57 (Unix) configured -- resuming normal operations
[Sun Jul 02 18:57:55.268750 2023] [core:notice] [pid 127:tid 281473783767136] AH00094: Command line: '/usr/local/apache2/bin/httpd -D FOREGROUND'

But when I want to open the domain of nextcloud on the same network I get this error:

on other networks I get this error:

What is my problem?

Network is local router which have opened ports of 11000 and 8443 and 8080 and also 80 and 443.
(I know it’s too much but I want to make it work right now)

thanks for help.

You need to pass the name and ip of your external proxy

docker run --name nextcloud-aio-mastercontainer \
--restart=unless-stopped \
--sig-proxy=false \
--publish 8080:8080 \
--env APACHE_PORT=11000 \
--volume nextcloud_aio_mastercontainer:/mnt/docker-aio-config \
--volume /var/run/docker.sock:/var/run/docker.sock:ro \

No, you dont.

@Shahin-rmz can you follow

Dear @szaimen this I posted was what worked for me. I read and reread the documentation and tested many combinations.
I put in a practical way what worked for me to help @Shahin-rmz.

If you have a better way, could you put a practical example directly here too?