Installing NCP on Docker - RPI4 2G - Problems with external storage

Hello, Im now trying for quite some time to get Nextcloud running. I got Nextcloud to work many times but never on my second partition of my ssd. Because it all the time gets stuck on the myip/activate screen after clicking activate. I also tried installing it on the home Directory of my pi, wich worked flawless but then i cant add the second partition (where its not installed) as an external storage source. I mounted everything correctly as lsblk reports

sda 8:0 0 447.1G 0 disk
├─sda1 8:1 0 256M 0 part /boot
├─sda2 8:2 0 29.3G 0 part /
└─sda3 8:3 0 417.6G 0 part /media/speicher1
sdb 8:16 0 931.5G 0 disk
└─sdb1 8:17 0 931.5G 0 part /media/backup

I assume its a Docker problem with permissions but havent found anything working for me in any Guides. My current installation is based on this Guide from the forum ncp docker getting started.

Thanks for your help in advance

the host system has to share the mount of your disk with a specific container you can achive this with an proper docker-compose file